Bug 1571811 - set the VDO writepolicy to auto
Summary: set the VDO writepolicy to auto
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Gdeploy
Version: 0.11.20
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ovirt-4.2.4
: 0.11.25
Assignee: Gobinda Das
QA Contact: bipin
URL:
Whiteboard:
Depends On:
Blocks: 1571810 cockpit-ovirt-0.11.28
TreeView+ depends on / blocked
 
Reported: 2018-04-25 13:07 UTC by SATHEESARAN
Modified: 2018-06-26 08:43 UTC (History)
4 users (show)

Fixed In Version: cockpit-ovirt-0.11.25-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1571810
Environment:
Last Closed: 2018-06-26 08:43:57 UTC
oVirt Team: Gluster
rule-engine: ovirt-4.2?
sasundar: planning_ack?
rule-engine: devel_ack+
bshetty: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 90772 0 master MERGED Set writepolicy value to auto for VDO 2018-05-23 11:39:14 UTC
oVirt gerrit 91533 0 ovirt-4.2 MERGED Set writepolicy value to auto for VDO 2018-05-23 11:39:28 UTC

Description SATHEESARAN 2018-04-25 13:07:10 UTC
+++ This bug was initially created as a clone of Bug #1571810 +++

Description of problem:
-----------------------
Set the VDO writepolicy to auto in the generated gdeploy configuration file


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
cockpit-ovirt-dashboard-0.11.22

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Start RHHI installation from cockpit UI
2. Enable dedupe and compression
3. Check for the VDO parameter set on the generated config file

Actual results:
---------------
Writepolicy is set to sync

Expected results:
-----------------
Writepolicy should be set to 'auto'

Additional info:
------------------
gdeploy now supports VDO writepolicy of 'auto'
https://bugzilla.redhat.com/show_bug.cgi?id=1552070

Comment 1 bipin 2018-05-31 13:20:46 UTC
Verified the bug with latest cockpit-ovirt-dashboard-0.11.25-1.

Output:

[vdo1:10.70.45.29]
action=create
devices=sdb,sde
names=vdo_sdb,vdo_sde
logicalsize=164840G,3000G
blockmapcachesize=128M
readcache=enabled
readcachesize=20M
emulate512=on  <---
writepolicy=auto
ignore_vdo_errors=no
slabsize=32G,32G

Comment 2 Sandro Bonazzola 2018-06-26 08:43:57 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.