Bug 1571815 - [RFE] Report status of Puppet run ability in web UI
Summary: [RFE] Report status of Puppet run ability in web UI
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Capsule
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Stephen Wadeley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-25 13:10 UTC by Stephen Wadeley
Modified: 2019-11-04 14:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-04 14:03:37 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Stephen Wadeley 2018-04-25 13:10:05 UTC
Description of problem:

The ability of a Capsule to do a Puppet run is not listed in web UI


Version-Release number of selected component (if applicable):
~]# rpm -q satellite
satellite-6.3.1-3.el7sat.noarch



Steps to Reproduce:
1. Navigate to Infrastructure > Capsules
2. Notice "Features" does not include Puppet run capability
3. Select a Capsule by name
4. See "Active features" on the Overview tab for a Capsule.

Actual results:

Feature list is not complete

Expected results:

Puppet run is included in list of "Active features" if enabled.

Comment 2 Ondřej Pražák 2018-12-13 09:57:12 UTC
Could you please expand on what you mean by 'Puppet run ability'? Do I understand correctly that you would like an indication when Capsule has a provider for running/kicking Puppet agents (configured by --foreman-proxy-puppetrun-provider option in installer)?

Comment 3 Stephen Wadeley 2018-12-13 17:47:25 UTC
Hello Ondřej


This bug was raised when I was testing the ability to trigger a Puppet run with ewoud's help[1], and he commented on the fact that you could not tell in advance if the Capsule had the ability to do a Puppet run, whereas as you could check other "Active features".

Looking in Sat6.5, I see the satellite installer has these options related to this ability:
    --foreman-puppetrun           Should Foreman be able to start Puppet runs on nodes (current: false)
    --foreman-proxy-puppet        Enable Puppet module for environment imports and Puppet runs (current: true)
    --foreman-proxy-puppetrun-provider  Provider for running/kicking Puppet agents (current: UNDEF)

I think "--foreman-proxy-puppetrun-provider" is not the priority here; I think checking the status of the other options is more important to determine if a Capsule is able to perform Puppet runs, and then advertise that in the "Active features" list.

If --foreman-proxy-puppetrun-provider is not set to use Puppet, does that mean the Capsule does not have Puppet run feature active? I suppose it does. So maybe all three need to be used as factors before advertising Puppet run feature active.


Lets ask ewoud to review this list.

Thank you

[1] Bug 1432111 - Describe "Run puppet" GUI button

Comment 4 Ewoud Kohl van Wijngaarden 2019-09-12 16:34:30 UTC
There's 2 parts to this functionality.

First of all on the Foreman side we have a global setting to enable/disable the Puppet Run button. In https://github.com/theforeman/puppet-foreman/commit/458f93ad21937a7583cad57927e42917cddd8447 we've dropped the installer parameter. In a future release you can enable/disable at runtime in the UI but until then (at least in 6.6) this must be set via the installer.

On the proxy side the Puppet module can have a puppetrun provider. This is named after functionality in Puppet 2 which could trigger Puppet runs on remote agents via the master. In Puppet 3 this was renamed to puppet kick but in Puppet 4 it was dropped.

In the smart-proxy we have multiple providers. The ones remaining are mcollective, salt, ssh and customrun. Mcollective and salt are unsupported within Satellite so only ssh and customrun possible implementations. Remote Execution is an easier to support implementation so within downstream I'd suggest we deprecate the Puppet Run functionality.

Comment 5 Bryan Kearney 2019-11-04 14:03:37 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.