Bug 1571818 - Cloud-init randomly fail to get nova metadata
Summary: Cloud-init randomly fail to get nova metadata
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-novajoin
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Ade Lee
QA Contact: Prasanth Anbalagan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-25 13:13 UTC by Marian Krcmarik
Modified: 2018-06-27 13:55 UTC (History)
7 users (show)

Fixed In Version: python-novajoin-1.0.18-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:53:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1766824 None None None 2018-04-25 13:13:34 UTC
OpenStack gerrit 564137 None master: MERGED novajoin: Add a retry loop when fetching vendor_data from novajoin (I728c2cb0c8a7433b68dd7de2de242e922974d713) 2018-05-03 12:04:16 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:55:00 UTC

Description Marian Krcmarik 2018-04-25 13:13:35 UTC
Description of problem:
From time to time it seems that we experience contention on novajoin, which makes cloud-init fail to retrieve metadata when doing:

curl -s http://169.254.169.254/openstack/2016-10-06/vendor_data2.json

To workaround the chances of contention we currently have a random sleep before that call so lower the odds that many nodes call novajoin at the same time.

This random sleep reduces the failure rate at deploy time but we can still experience it fairly often.

The end result often is that overcloud nodes end up without cert and overcloud deployment fails, the probability raises with number of nodes

Version-Release number of selected component (if applicable):


How reproducible:
often

Steps to Reproduce:
1. Deploy overcloud of Openstack with TLS everywhere.

Actual results:
Overcloud deployment fails since some certs are missing on some overcloud nodes


Additional info:

Comment 1 Damien Ciabrini 2018-04-25 14:46:38 UTC
Proposed https://review.openstack.org/#/c/564137/3 to overcome the failures.

Comment 9 errata-xmlrpc 2018-06-27 13:53:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.