Bug 1571830 - [RHV] Last boot time not updated for a VM in UI
Summary: [RHV] Last boot time not updated for a VM in UI
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.10.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: GA
: cfme-future
Assignee: Martin Perina
QA Contact: Ganesh Hubale
Red Hat CloudForms Documentation
URL:
Whiteboard: rhev
: 1723307 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-25 13:34 UTC by Jan Zmeskal
Modified: 2019-12-18 18:27 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-18 18:27:13 UTC
Category: ---
Cloudforms Team: RHEVM
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Zmeskal 2018-04-25 13:34:43 UTC
Description of problem:
When you reboot newly provisioned VM from CFME admin UI, the last boot time is not updated after the reboot finished.

Version-Release number of selected component (if applicable):
CFME 5.9.2.3
RHV 4.2.2.5

How reproducible:
100 %

Steps to Reproduce:
1. Have a CFME appliance with RHV as infrastructure provider
2. Provision a VM from a template on RHV, wait for the provision to finish and make sure that the VM is up
3. Go to Details page of your VM and locate field Power Management -> Last Boot Time and take note of it
4. Now click Power -> Restart Guest and wait for the VM to fully finish the reboot process
5. Click Configuration -> Refresh Relationships and Power States
6. Inspect Last Boot Time again

Actual results:
Last Boot Time stays the same it was after the VM was provisioned.

Expected results:
I would expect this item to be updated since a reboot took place.

Additional info:
I noticed this is not necessarily case on other VMs. I have tried the same on a VM that has been running in my env for some time (circa three days) and Last Boot Time was updated for it. Unfortunately I have no idea what's the difference between them. The old VM has been created from the very same template and I did not change anything on it.

Comment 4 Jan Zmeskal 2018-04-30 07:58:23 UTC
Additional info:
I tried to reproduce the same with vSphere Client version 6.5.0.10000 as a provider and I did not run into this behaviour.

Comment 7 Adam Grare 2019-06-24 13:23:28 UTC
*** Bug 1723307 has been marked as a duplicate of this bug. ***

Comment 8 Adam Grare 2019-06-24 13:25:50 UTC
Jan this says it is an issue with RHV so you can't test with vSphere.

On RHV we get the boot_time from the vm.start_time so if restarting the guest doesn't change that property, our boot_time won't be updated either.  Looking to Martin/Boris to confirm that.

Comment 9 Adam Grare 2019-06-24 13:28:08 UTC
Going to reopen and update the version, but I suspect this might be expected behavior if RHV doesn't update the start_time on a guest reboot.

Comment 10 Ganesh Hubale 2019-07-04 08:58:39 UTC
Hi,

This BZ is reproducible on 5.11z too. Hence we need clone of it for 5.11z.

Thanks,
Ganesh


Note You need to log in before you can comment on or make changes to this bug.