Bug 1571836 - OSPD 13 Undercloud - Infrastructure Provider Network Manager does not refreshed
Summary: OSPD 13 Undercloud - Infrastructure Provider Network Manager does not refreshed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.9.0
Hardware: x86_64
OS: Linux
high
urgent
Target Milestone: GA
: 5.10.0
Assignee: Sam Lucidi
QA Contact: Ido Ovadia
URL:
Whiteboard:
: 1571802 (view as bug list)
Depends On:
Blocks: 1572760
TreeView+ depends on / blocked
 
Reported: 2018-04-25 13:45 UTC by Ido Ovadia
Modified: 2019-02-11 14:01 UTC (History)
9 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1572760 (view as bug list)
Environment:
Last Closed: 2019-02-11 14:01:54 UTC
Category: ---
Cloudforms Team: Openstack
Target Upstream Version:


Attachments (Terms of Use)

Description Ido Ovadia 2018-04-25 13:45:16 UTC
Description of problem:
=======================
Undercloud Network Manager does not refreshed, therefor it does not show any Networks, Subnets and Port connects to it  

Version-Release number of selected component:
=============================================
CFME 5.9.2.3 

How reproducible:
=================
100%

Steps to Reproduce:
===================
1. Browse: Networks --> Providers 
2. Select Infrastructure Provider (Undercloud) Network Manager  
3. Click Configuration --> Refresh Relationships and Power States

Actual results:
===============
Last Refresh: Never
Network Manager does not show any Networks, Subnets and Port connects to it

Expected results:
=================
Refresh should finish successfully,
Relationships should update with correct number of Networks, Subnets and Port 

Additional info:

Comment 2 Sam Lucidi 2018-04-25 21:22:26 UTC
https://github.com/ManageIQ/manageiq-providers-openstack/pull/280

It appears a 404 manifesting as Fog::Errors::NotFound instead of Excon::Errors::NotFound was causing refresh to fail. The above PR should fix it.

Comment 3 Ido Ovadia 2018-04-26 06:50:10 UTC
*** Bug 1571802 has been marked as a duplicate of this bug. ***

Comment 4 Marianne Feifer 2018-04-27 17:31:47 UTC
Hey Sam!  Looks like the PR was merged.  Can this go to POST?

Comment 5 Sam Lucidi 2018-04-27 18:36:11 UTC
Yep, thanks!

Comment 8 Ido Ovadia 2018-07-09 12:28:25 UTC
Verified
========
5.10.0.3


Note You need to log in before you can comment on or make changes to this bug.