Bug 1571849 - USB controllers not written to snapshots
Summary: USB controllers not written to snapshots
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.2.3
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.2.4
: ---
Assignee: Arik
QA Contact: Nisim Simsolo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-25 14:14 UTC by Arik
Modified: 2018-06-26 08:37 UTC (History)
2 users (show)

Fixed In Version: ovirt-engine-4.2.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 08:37:33 UTC
oVirt Team: Virt
rule-engine: ovirt-4.2+
rule-engine: blocker+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 90648 0 master MERGED core: write usb controllers to ovf again 2018-04-26 08:48:49 UTC
oVirt gerrit 90687 0 ovirt-engine-4.2 MERGED core: write usb controllers to ovf again 2018-04-30 12:08:51 UTC

Description Arik 2018-04-25 14:14:06 UTC
Description of problem:
Due to a regression introduced in 4.2 USB controllers stopped being written to OVFs.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a VM with USB support enabled.
2. Take a snapshot.
3. Preview the snapshot.

Actual results:
USB controllers are missing, That would block the VM from being started.

Expected results:
The VM should be restored with the same devices, in particular, USB controllers.

Additional info:

Comment 1 Red Hat Bugzilla Rules Engine 2018-04-25 14:14:43 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 2 Nisim Simsolo 2018-05-28 13:47:10 UTC
Verified:
rhvm-4.2.4-0.1.el7
libvirt-client-3.9.0-14.el7_5.5.x86_64
sanlock-3.6.0-1.el7.x86_64
qemu-kvm-rhev-2.10.0-21.el7_5.3.x86_64
vdsm-4.20.28-1.el7ev.x86_64

Verification scenario:
1. Create a VM with USB support enabled, from console -> file -> attach USB to VM and from VM itself verify USB attached is functional.
2. Take a snapshot.
3. Preview the snapshot.
4. Verify USB controllers are restored.

Comment 3 Sandro Bonazzola 2018-06-26 08:37:33 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.