Bug 1571851 - Unplugged devices not written to OVF
Summary: Unplugged devices not written to OVF
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.2.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Shmuel Melamud
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-25 14:19 UTC by Arik
Modified: 2018-06-29 14:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-15 10:50:19 UTC
oVirt Team: Virt


Attachments (Terms of Use)

Description Arik 2018-04-25 14:19:54 UTC
Description of problem:
It seems that unplugged devices are not being written to OVFs.
This needs to be investigated.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a VM with 2 disks.
2. Unplug one of the disks.
3. Create a VM snapshot.
4. Preview the snapshot.

Actual results:
The VM is missing the unplugged disk.

Expected results:
There should be a device for the unplugged disk.

Additional info:

Comment 1 Shmuel Melamud 2018-05-15 10:50:19 UTC
Cannot reproduce the bug. After creating a VM snapshot and previewing it the unplugged disk still exists along with plugged ones.

Also, manual investigation of the OVF files show that the unplugged disk is present in them, as follows:

<Section xsi:type="ovf:VirtualHardwareSection_Type">
...
    <Item>
        <rasd:Caption>VM-unplugged-disk_Disk1</rasd:Caption>
        ...
        <Type>disk</Type>
        <Device>disk</Device>
        <rasd:Address />
        <BootOrder>1</BootOrder>
        <IsPlugged>false</IsPlugged>
        <IsReadOnly>false</IsReadOnly>
        <Alias />
     </Item>
...
</Section>


Note You need to log in before you can comment on or make changes to this bug.