Bug 1571859 - Handle satellite 6.3 with puppet 3 upgrade to satellite 6.4
Summary: Handle satellite 6.3 with puppet 3 upgrade to satellite 6.4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Foreman Maintain
Version: 6.3.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: 6.4.0
Assignee: Kavita
QA Contact: Nikhil Kathole
URL:
Whiteboard:
: 1585792 1626531 1632083 (view as bug list)
Depends On:
Blocks: 1496794 1619394
TreeView+ depends on / blocked
 
Reported: 2018-04-25 14:33 UTC by Nikhil Kathole
Modified: 2019-11-05 23:16 UTC (History)
10 users (show)

Fixed In Version: foreman_maintain-0.2.6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-16 15:16:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 23819 0 Normal Closed Handle satellite 6.3 with puppet 3 upgrade to satellite 6.4 2020-01-31 21:07:15 UTC
Red Hat Bugzilla 1626531 0 high CLOSED [RFE] Foreman-maintain should have a puppet version pre-check 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 1632083 0 unspecified CLOSED failed to upgrade to 6.4 due to puppet dependency 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHBA-2018:2926 0 None None None 2018-10-16 15:17:24 UTC

Internal Links: 1626531 1632083

Description Nikhil Kathole 2018-04-25 14:33:41 UTC
Description of problem: We need some more checks and modifications regarding puppet. As satellite 6.3. puppet3 -> sat6.4 update failed due to dependency

--> Finished Dependency Resolution
Error: Package: puppet-server-3.8.6-4.el7sat.noarch (@rhel-7-server-satellite-6.3-rpms)
           Requires: puppet = 3.8.6-4.el7sat
           Removing: puppet-3.8.6-4.el7sat.noarch (@rhel-7-server-satellite-6.3-rpms)
               puppet = 3.8.6-4.el7sat
           Obsoleted By: puppet-agent-5.5.0-1.el7sat.x86_64 (sat6)
               puppet >= 4.0.0-1.el7sat

and upgrade path will be sat 63 with puppet4 -> sat64. So possible twicks can be if 6.3 with puppet3, raise warning (do not allow ) upgrade to 6.4 or add support to f-m to update sat 63 to puppet4.


Version-Release number of selected component (if applicable): 


How reproducible:always


Steps to Reproduce:
1. Install 6.3 with puppet 3
2. yum update

Actual results: 

--> Finished Dependency Resolution
Error: Package: puppet-server-3.8.6-4.el7sat.noarch (@rhel-7-server-satellite-6.3-rpms)
           Requires: puppet = 3.8.6-4.el7sat
           Removing: puppet-3.8.6-4.el7sat.noarch (@rhel-7-server-satellite-6.3-rpms)
               puppet = 3.8.6-4.el7sat
           Obsoleted By: puppet-agent-5.5.0-1.el7sat.x86_64 (sat6)
               puppet >= 4.0.0-1.el7sat


Expected results:


Additional info:

Comment 2 Ivan Necas 2018-04-25 14:44:03 UTC
Since the upgrade of puppet can be quite complex (depending on how much of Puppet is used in the infrastucture). Therefore, I would like to keep the scope of this BZ to check the puppet3 presence in pre-upgrade for 6.4 and pointing the user to proceed with https://access.redhat.com/documentation/en-us/red_hat_satellite/6.3/html/upgrading_and_updating_red_hat_satellite/upgrading_puppet-1 before continuing.

Comment 3 Mike McCune 2018-06-05 15:32:02 UTC
+1 to Ivan's comment above, error out with a pointer to the docs

Comment 4 Ivan Necas 2018-06-05 15:32:49 UTC
Created redmine issue http://projects.theforeman.org/issues/23819 from this bug

Comment 5 Ivan Necas 2018-06-06 13:49:42 UTC
*** Bug 1585792 has been marked as a duplicate of this bug. ***

Comment 6 pm-sat@redhat.com 2018-06-08 12:18:38 UTC
Upstream bug assigned to apatel@redhat.com

Comment 7 pm-sat@redhat.com 2018-06-11 10:17:40 UTC
Upstream bug assigned to kgaikwad@redhat.com

Comment 8 pm-sat@redhat.com 2018-06-22 08:21:17 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/23819 has been resolved.

Comment 10 Nikhil Kathole 2018-07-31 12:25:58 UTC
FailedQA

Version tested:
# rpm -qa | grep maintain
rubygem-foreman_maintain-0.2.4-1.el7sat.noarch

Comment 14 Nikhil Kathole 2018-08-07 12:43:54 UTC
VERIFIED

Version tested:
# rpm -qa | grep maintain
rubygem-foreman_maintain-0.2.6-1.el7sat.noarch

On satellite 6.3 with puppet 3,

--------------------------------------------------------------------------------
Verify puppet and provide upgrade guide for it: 
\ current puppet version: puppet-3.8.6-4.el7sat.noarch                [FAIL]    
Before continuing with upgrade, please make sure you finish puppet upgrade.
--------------------------------------------------------------------------------
Continue with step [Show knowledge base article for troubleshooting]?, [y(yes), n(no), q(quit)] y
Show knowledge base article for troubleshooting:                                
Go to https://access.redhat.com/documentation/en-us/red_hat_satellite/6.3/html/upgrading_and_updating_red_hat_satellite/upgrading_puppet-1
please follow steps from above article to resolve this issue
press ENTER once done.

                                                                      [OK]
--------------------------------------------------------------------------------

On satellite 6.3 with puppet 4,

--------------------------------------------------------------------------------
Verify puppet and provide upgrade guide for it: 
- current puppet version:                                             [OK]      
--------------------------------------------------------------------------------

Check available only on sat 6.3.For sat 6.4 check doesn't exist.

Comment 15 Mihir Lele 2018-09-07 16:33:16 UTC
*** Bug 1626531 has been marked as a duplicate of this bug. ***

Comment 17 Ivan Necas 2018-09-25 07:29:55 UTC
*** Bug 1632083 has been marked as a duplicate of this bug. ***

Comment 21 errata-xmlrpc 2018-10-16 15:16:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2926


Note You need to log in before you can comment on or make changes to this bug.