Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1571869 - [IPv6] add host does not maintain ipv6 default route
Summary: [IPv6] add host does not maintain ipv6 default route
Keywords:
Status: CLOSED DUPLICATE of bug 1467332
Alias: None
Product: vdsm
Classification: oVirt
Component: Core
Version: 4.20.23
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.3.0
: ---
Assignee: Dan Kenigsberg
QA Contact: Meni Yakove
URL:
Whiteboard:
Depends On:
Blocks: RHEV_IPv6
TreeView+ depends on / blocked
 
Reported: 2018-04-25 14:53 UTC by Piotr Kliczewski
Modified: 2018-09-03 10:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-03 10:34:52 UTC
oVirt Team: Network
rule-engine: ovirt-4.3+


Attachments (Terms of Use)
logs (1.51 MB, application/x-gzip)
2018-04-25 14:54 UTC, Piotr Kliczewski
no flags Details

Description Piotr Kliczewski 2018-04-25 14:53:10 UTC
Description of problem:

When a machine uses ipv6 for name resolution and after vdsm installation it is not possible to resolve names.

Here is my nic configuration before installation:

TYPE="Ethernet"
BOOTPROTO="dhcp"
DEFROUTE="yes"
PEERDNS="yes"
PEERROUTES="yes"
IPV4_FAILURE_FATAL="no"
IPV6INIT="yes"
IPV6_AUTOCONF="yes"
IPV6_DEFROUTE="yes"
IPV6_PEERDNS="yes"
IPV6_PEERROUTES="yes"
IPV6_FAILURE_FATAL="no"
NAME="eth0"
UUID="0079668a-8708-46ad-8dbf-da418ae6f77e"
DEVICE="eth0"
ONBOOT="yes"

here is after:

# Generated by VDSM version 4.20.23-1.el7.centos
DEVICE=eth0
BRIDGE=ovirtmgmt
ONBOOT=yes
MTU=1500
DEFROUTE=no
NM_CONTROLLED=no
IPV6INIT=no

and the bridge:
# Generated by VDSM version 4.20.23-1.el7.centos
DEVICE=ovirtmgmt
TYPE=Bridge
DELAY=0
STP=off
ONBOOT=yes
BOOTPROTO=dhcp
MTU=1500
DEFROUTE=yes
NM_CONTROLLED=no
IPV6INIT=yes
DHCPV6C=yes
IPV6_AUTOCONF=no

my resolv.conf

; generated by /usr/sbin/dhclient-script
nameserver 2001:730:3ed2::53
nameserver 2001:730:3ed2:1000::53
search localdomain

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1. Install new host on a vm configured like above

Actual results:
Occurs 100% with above network configuration

Expected results:
Name resolution still works

Additional info:

Comment 1 Piotr Kliczewski 2018-04-25 14:54:43 UTC
Created attachment 1426729 [details]
logs

There was attempt to install host few times (engine.log). Please ignore the failures (missing rpms or nested not enabled) and check the last successful installation.

Comment 2 Dan Kenigsberg 2018-04-27 07:58:02 UTC
The ipv6 address is not maintained because of bug 1373116: Engine does not request Vdsm to keep autoconf on. Let this bug track only the failure to maintain ipv6 default route.

Comment 3 Yaniv Lavi 2018-09-03 10:34:52 UTC

*** This bug has been marked as a duplicate of bug 1467332 ***


Note You need to log in before you can comment on or make changes to this bug.