Bug 1571894 - lsmcli [command] --init "wrong" return --init-id "None" in error instead of --init "wrong"
Summary: lsmcli [command] --init "wrong" return --init-id "None" in error instead of -...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libstoragemgmt
Version: 7.6
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Tony Asleson
QA Contact: Jakub Krysl
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-25 15:44 UTC by Jakub Krysl
Modified: 2019-08-06 12:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 12:40:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2064 None None None 2019-08-06 12:40:29 UTC

Description Jakub Krysl 2018-04-25 15:44:22 UTC
Description of problem:
When --init is given wrong value, the error message contains "None" instead of this value. Plus the parameter is --init and not --init-id as said in the message.

# lsmcli -u "sim://" access-group-create --name test --sys sim-01 --init "wrong"
lsmcli: error: --init-id None is not a valid WWPN or iSCSI IQN
# lsmcli -u "sim://" access-group-create --name test --sys sim-01 --init 0
lsmcli: error: --init-id None is not a valid WWPN or iSCSI IQN

# lsmcli -u "sim://" access-group-remove --ag AG_ID_00001 --init "wrong"
lsmcli: error: --init-id None is not a valid WWPN or iSCSI IQN


Version-Release number of selected component (if applicable):
libstoragemgmt-1.6.1-2.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.# lsmcli -u "sim://" access-group-create --name test --sys sim-01 --init "wrong"

Actual results:
lsmcli: error: --init-id None is not a valid WWPN or iSCSI IQN

Expected results:
lsmcli: error: --init "wrong" is not a valid WWPN or iSCSI IQN

Additional info:

Comment 3 Jakub Krysl 2019-01-28 16:58:06 UTC
libstoragemgmt-1.7.2-1.el7.x86_64

# lsmcli -u "sim://" iscsi-chap --init='WRONG'
usage: lsmcli iscsi-chap [-h] [-v] [-u <URI>] [-P] [-H] [-t <SEP>] [-e] [-f]
                         [-w CHILD_WAIT] [--header] [-b] [-s] --init <INIT_ID>
                         [--in-user <IN_USER>] [--in-pass <IN_PASS>]
                         [--out-user <OUT_USER>] [--out-pass <OUT_PASS>]
lsmcli iscsi-chap: error: argument --init: "WRONG" is invalid WWPN or iSCSI IQN

Comment 5 errata-xmlrpc 2019-08-06 12:40:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2064


Note You need to log in before you can comment on or make changes to this bug.