Bug 1571929 - After stack delete ironic has leftovers
Summary: After stack delete ironic has leftovers
Keywords:
Status: CLOSED DUPLICATE of bug 1560690
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 13.0 (Queens)
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: RHOS Maint
QA Contact: Amit Ugol
URL:
Whiteboard: scale_lab
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-25 18:05 UTC by Joe Talerico
Modified: 2018-05-24 15:41 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-24 15:41:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 564104 0 None None None 2018-05-04 20:30:33 UTC

Description Joe Talerico 2018-04-25 18:05:48 UTC
Description of problem:
(undercloud) [stack@c09-h23-r630 ~]$ heat stack-list
WARNING (shell) "heat stack-list" is deprecated, please use "openstack stack list" instead
+----+------------+--------------+---------------+--------------+
| id | stack_name | stack_status | creation_time | updated_time |
+----+------------+--------------+---------------+--------------+
+----+------------+--------------+---------------+--------------+
(undercloud) [stack@c09-h23-r630 ~]$ for node in `openstack baremetal node list --fields uuid | awk '{print $2}'`; do
> ironic node-vif-list $node
> done
The "ironic" CLI is deprecated and will be removed in the S* release. Please use the "openstack baremetal" CLI instead.
Node UUID could not be found. (HTTP 404)
The "ironic" CLI is deprecated and will be removed in the S* release. Please use the "openstack baremetal" CLI instead.
+----+
| ID |
+----+
+----+
The "ironic" CLI is deprecated and will be removed in the S* release. Please use the "openstack baremetal" CLI instead.
+----+
| ID |
+----+
+----+
The "ironic" CLI is deprecated and will be removed in the S* release. Please use the "openstack baremetal" CLI instead.
+----+
| ID |
+----+
+----+
The "ironic" CLI is deprecated and will be removed in the S* release. Please use the "openstack baremetal" CLI instead.
+----+
| ID |
+----+
+----+
The "ironic" CLI is deprecated and will be removed in the S* release. Please use the "openstack baremetal" CLI instead.
+----+
| ID |
+----+
+----+
The "ironic" CLI is deprecated and will be removed in the S* release. Please use the "openstack baremetal" CLI instead.
+----+
| ID |
+----+
+----+
The "ironic" CLI is deprecated and will be removed in the S* release. Please use the "openstack baremetal" CLI instead.
+----+
| ID |
+----+
+----+
The "ironic" CLI is deprecated and will be removed in the S* release. Please use the "openstack baremetal" CLI instead.
+----+
| ID |
+----+
+----+
The "ironic" CLI is deprecated and will be removed in the S* release. Please use the "openstack baremetal" CLI instead.
+--------------------------------------+
| ID                                   |
+--------------------------------------+
| 8e0580ad-bbd8-429f-a841-b4bc0f03865b |
+--------------------------------------+
The "ironic" CLI is deprecated and will be removed in the S* release. Please use the "openstack baremetal" CLI instead.
+----+
| ID |
+----+
+----+
The "ironic" CLI is deprecated and will be removed in the S* release. Please use the "openstack baremetal" CLI instead.
+----+
| ID |
+----+
+----+
The "ironic" CLI is deprecated and will be removed in the S* release. Please use the "openstack baremetal" CLI instead.
+----+
| ID |
+----+
+----+
The "ironic" CLI is deprecated and will be removed in the S* release. Please use the "openstack baremetal" CLI instead.
+----+
| ID |
+----+
+----+

Version-Release number of selected component (if applicable):
OSP13

How reproducible:
50%

Steps to Reproduce:
1. Deploy, Delete overcloud
2. Redeploy same cloud


Actual results:
Deployed cloud

Expected results:
Error : 
2018-04-25 17:18:54Z [overcloud.Compute.0.NovaCompute]: CREATE_FAILED  ResourceInError: resources.NovaCompute:Went to status ERROR due to "Message: Build of instance 23e371dc-7a4a-48ba-8f98-76a04168f924 aborted: Failure prepping block device., Code: 500"


Additional info:

Comment 1 Sai Sindhur Malleni 2018-04-25 18:08:28 UTC
Yes, especially there are a lot of neutron ports leftover from previous deploy.

Comment 2 Joe Talerico 2018-04-25 18:12:09 UTC
Swap the Actual and Expected results above :)


Possibly related to : https://bugzilla.redhat.com/show_bug.cgi?id=1560690

Comment 3 Thomas Hervé 2018-04-25 18:31:40 UTC
Looks like https://bugs.launchpad.net/heat/+bug/1766763

Comment 4 Bob Fournier 2018-05-24 15:41:21 UTC
Marking as duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1560690. A heat fix has been made to remove internal ports.

*** This bug has been marked as a duplicate of bug 1560690 ***


Note You need to log in before you can comment on or make changes to this bug.