Bug 1571948 - [upstream][v2v] Migration Plan CSV import screen readability issue for VMs with long name
Summary: [upstream][v2v] Migration Plan CSV import screen readability issue for VMs wi...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: GA
: 5.9.3
Assignee: Dan Clarizio
QA Contact: Dave Johnson
URL:
Whiteboard: v2v
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-25 19:07 UTC by Kedar Kulkarni
Modified: 2018-05-03 13:58 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-02 16:48:47 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
Screenshot (26.78 KB, image/png)
2018-04-25 19:07 UTC, Kedar Kulkarni
no flags Details
No longer an issue, latest alpha branch reports csv imports in a table that wraps (207.89 KB, image/png)
2018-05-01 12:49 UTC, Allen W
no flags Details

Description Kedar Kulkarni 2018-04-25 19:07:42 UTC
Created attachment 1426790 [details]
Screenshot

Description of problem:
Please see attached screenshot
Migration Plan CSV import screen readability issue for VMs with long name as the VM name invades in between provider and reference. Text should be wrapped. 

Version-Release number of selected component (if applicable):
master.20180424003235_96b2aa1

How reproducible:
100%

Steps to Reproduce:
1.Go to Infrastructure -> Migration-> Overview -> Create Migration Plan
2.Import a CSV in the wizard, which has a VM with really long name like 65 chars long
3.See screenshot

Actual results:
See screenshot


Expected results:
Text should be wrapped. 

Additional info:

Comment 2 Brett Thurber 2018-04-29 06:10:21 UTC
Upstream issue here:  https://github.com/priley86/miq_v2v_ui_plugin/issues/259

Comment 3 Allen W 2018-04-30 16:11:52 UTC
OoooooOOOooOOoooo I'll jump on this one, we have a solution employed elsewhere in the app, truncate with ellipses and throw up a tooltip with the rest of the name...

Comment 4 Allen W 2018-05-01 12:49:44 UTC
Created attachment 1429176 [details]
No longer an issue, latest alpha branch reports csv imports in a table that wraps

Comment 5 Allen W 2018-05-01 12:50:02 UTC
KK you ok for this to be closed? Soon as latest alpha is stabilized, in master, we'll be goooooood

Comment 6 Kedar Kulkarni 2018-05-01 13:04:01 UTC
Hey Allen, 

That looks good. Let me get my hands on Alpha, once done with it, I will close it. 

Hope that's okay. Not clearing needinfo yet, so that I will get reminder if I forget to close it.

Thanks,
KK.

Comment 7 Kedar Kulkarni 2018-05-02 16:48:47 UTC
Works for me in master.20180430231107_6437e92 upstream appliance.


Note You need to log in before you can comment on or make changes to this bug.