Bug 1571983 - [RFE] split role permission reconfigure vm (separate CPU/RAM/DISK/NETWORK/CD_ATTACH)
Summary: [RFE] split role permission reconfigure vm (separate CPU/RAM/DISK/NETWORK/CD_...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.10.11
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: GA
: cfme-future
Assignee: Harpreet Kataria
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-25 21:21 UTC by Reartes Guillermo
Modified: 2019-12-18 14:36 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-18 14:36:07 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
role screenshot 4.6 (68.16 KB, image/png)
2018-04-25 21:22 UTC, Reartes Guillermo
no flags Details
reconfigure vm screenshot 4.6 (separate color for the sections to disable) (26.64 KB, image/png)
2018-04-25 21:24 UTC, Reartes Guillermo
no flags Details

Description Reartes Guillermo 2018-04-25 21:21:43 UTC
Description of problem:

I encountered a situation in which i had to implement a custom add disk to VM method and dialog. (With storage tiers).

I noticed that this led to an unwanted situation, the reconfigure vm dialog functionality cannot be divided so i will have to disable all 3 reconfiguration (CPU/MEMORY/DISK) and re-implement CPU/MEMORY alongside the new custom DISK reconfiguration.

That should not be this way, since the default CPU/MEMORY reconfiguration provided by CloudForms is Okay.

So, this RFE is for splitting the role permission "reconfigure vm" into "reconfigure vm cpu", "reconfigure vm memory" and "reconfigure vm disk". This will avoid unnecessary re-implementations.

Version-Release number of selected component (if applicable):
5.9.x

How reproducible:
N/A since is an RFE

Steps to Reproduce:
N/A since is an RFE

Actual results:

Having to re-implement both CPU and MEMORY reconfiguration when i should only need to re implement/implement the custom add disk to vm code. (and dialog and dynamic elements).

Expected results:

Being able to continue the default reconfiguration dialog for both CPU and MEMORY and also disabling DISK reconfiguration in order to implement a custom version with customer needs.

Additional info:
RFE

Comment 2 Reartes Guillermo 2018-04-25 21:22:11 UTC
Created attachment 1426871 [details]
role screenshot 4.6

Comment 3 Reartes Guillermo 2018-04-25 21:24:00 UTC
Created attachment 1426878 [details]
reconfigure vm screenshot 4.6 (separate color for the sections to disable)

Sorry, the example screenshot is from an archived VM, but that is what i got now.
I also thing that the disable feature should not be visiable, not just grayed down.

Comment 5 Reartes Guillermo 2019-11-04 17:55:57 UTC
The Network Adapters addition is unusable when using tenancy.
Giving "reconfigure" gives also the ability for user1 on tenant1 access to any tenant network.

The reconfigure screen is all-or-nothing for reconfiguration.


Note You need to log in before you can comment on or make changes to this bug.