Bug 1572022 - Unable to retrieve metrics from Openshift 3.7.23
Summary: Unable to retrieve metrics from Openshift 3.7.23
Keywords:
Status: CLOSED DUPLICATE of bug 1562090
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.9.3
Assignee: Yaacov Zamir
QA Contact: Einat Pacifici
URL:
Whiteboard:
Depends On:
Blocks: 1561041
TreeView+ depends on / blocked
 
Reported: 2018-04-26 02:29 UTC by Imaan
Modified: 2018-05-23 03:37 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-17 14:42:12 UTC
Category: ---
Cloudforms Team: Container Management
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3452671 0 None None None 2018-05-23 03:37:55 UTC

Description Imaan 2018-04-26 02:29:21 UTC
Description of problem:

CFME (5.9.1.2) is unable to aggregate metrics from Openshift cluster (3.7.23).

Version-Release number of selected component (if applicable):

5.9.1.2

Fails with following error :

[----] E, [2018-04-18T13:03:07.799809 #2050:962290c] ERROR -- : MIQ(ManageIQ::Providers::Openshift::ContainerManager::Ev
entCatcher::Runner#start_event_monitor) EMS [master.ocp-dev.hbs.net.au] as [] Event Monitor Thread aborted because [geta
ddrinfo: Name or service not known]
[----] E, [2018-04-18T13:03:07.799953 #2050:962290c] ERROR -- : [SocketError]: getaddrinfo: Name or service not known  M
ethod:[block in method_missing]
[----] E, [2018-04-18T13:03:07.799995 #2050:962290c] ERROR -- : /opt/rh/cfme-gemset/gems/http-0.9.8/lib/http/timeout/nul
l.rb:18:in `initialize'

Comment 3 Yaacov Zamir 2018-04-26 15:56:18 UTC
Imman, Thanks for the BZ.

The logs provided here, show manageIQ fail to connect to the url provided.

Can you attach screenshots of the container provider settings page ?

The most important parts are:
a. the url of the openshit provider
b. the url of hawkular
c. the status of connection and validation

Any other info you can show about the provider configuration and status can be helpful.


Note You need to log in before you can comment on or make changes to this bug.