Bug 1572032 - [ceph-ansible] - rolling update not working on cluster intialised using iso
Summary: [ceph-ansible] - rolling update not working on cluster intialised using iso
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 2.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 3.1
Assignee: Sébastien Han
QA Contact: subhash
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-26 03:40 UTC by Vasishta
Modified: 2018-09-26 18:20 UTC (History)
9 users (show)

Fixed In Version: RHEL: ceph-ansible-3.0.33-1.el7cp Ubuntu: ceph-ansible_3.0.33-2redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-26 18:19:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-ansible pull 2558 0 None None None 2018-05-03 14:56:59 UTC
Red Hat Product Errata RHBA-2018:2819 0 None None None 2018-09-26 18:20:44 UTC

Description Vasishta 2018-04-26 03:40:45 UTC
Description of problem:
rolling update completing its run without updating the cluster when cluster was initialised using iso image.

Version-Release number of selected component (if applicable):
ceph-ansible-3.0.25-1.el7cp.noarch

How reproducible:
Always (3/3)

Steps to Reproduce:
1. Configure ceph cluster using iso image (n-1 version)
2. Try to upgrade the cluster to latest version.

Actual results:
Cluster is not getting updated

Expected results:
Cluster must get updated

Additional info:

It can be observed that the task "copy red hat storage iso content for redhat systems" is not working as copying of latest iso contents to ceph_rhcs_repository_path is getting skipped as the file README exists in the directory already when previous iso contents were copied.

"changed": false,
    "cmd": "cp -r /tmp/rh-storage-mount/* /tmp/rh-storage-repo",
    "invocation": {
        "module_args": {
            "_raw_params": "cp -r /tmp/rh-storage-mount/* /tmp/rh-storage-repo",
            "_uses_shell": true,
            "chdir": null,
            "creates": "/tmp/rh-storage-repo/README",
            "executable": null,
            "removes": null,
            "stdin": null,
            "warn": true
        }
    },
    "rc": 0,
    "stdout": "skipped, since /tmp/rh-storage-repo/README exists",
    "stdout_lines": [
        "skipped, since /tmp/rh-storage-repo/README exists"

Comment 3 Ken Dreyer (Red Hat) 2018-05-10 21:50:10 UTC
Resolved in v3.0.33 (stable-3.0) and v3.1.0beta9 (stable-3.1).

Comment 6 subhash 2018-07-05 19:48:21 UTC
Brought up a ceph cluster using an (n-1)Iso,then Downloaded new ceph iso(n), replaced path,enabled upgrade_packages in all.yml and ran rolling update.yml.Cluster got upgraded to n version successfully.Hence moving to Verified 

Verified with version ceph-ansible-3.1.0-0.1.rc9.el7cp.noarch ,
ansible-2.4.5.0-1.el7ae.noarch

Comment 8 errata-xmlrpc 2018-09-26 18:19:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2819


Note You need to log in before you can comment on or make changes to this bug.