Bug 1572039 - [ESXi] "disk = (vim.vm.GuestInfo.DiskInfo)" section can't be shown with RHEL Atomic Host 7.*
Summary: [ESXi] "disk = (vim.vm.GuestInfo.DiskInfo)" section can't be shown with RHEL ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rhel-server-atomic
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Colin Walters
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-26 04:03 UTC by Yan Jin
Modified: 2021-02-15 07:38 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-15 07:38:42 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yan Jin 2018-04-26 04:03:07 UTC
Description of problem:

Running cmd "vim-cmd /vmsvc/get.guest *" on ESXi server to get Guest information of RHEL Atomic Host 7.* , it doesn't show the "disk = (vim.vm.GuestInfo.DiskInfo)" section about disk info etc.
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.putty log on ESXi server as root
2.Run "vim-cmd vmsvc/getallvms" to find Guest ID
3.Run "vim-cmd vmsvc/get.guest #GuestID" to get Guest information.


Actual results:
"disk = (vim.vm.GuestInfo.DiskInfo)" section is missed

Expected results:
"disk = (vim.vm.GuestInfo.DiskInfo)" section should be presented like below:
Guest information:

(vim.vm.GuestInfo) {
   toolsStatus = "toolsOk",
   toolsVersionStatus = "guestToolsUnmanaged",
   toolsVersionStatus2 = "guestToolsUnmanaged",
   toolsRunningStatus = "guestToolsRunning",
   toolsVersion = "10277",
   toolsInstallType = "guestToolsTypeOpenVMTools",
   toolsUpdateStatus = (vim.vm.GuestInfo.ToolsUpdateStatus) null,
   guestId = "rhel7_64Guest",
   guestFamily = "linuxGuest",
   guestFullName = "Red Hat Enterprise Linux 7 (64-bit)",
   hostName = "atomic0",
   ipAddress = "10.117.16.1",
   net = (vim.vm.GuestInfo.NicInfo) [
   ...
   ],
   disk = (vim.vm.GuestInfo.DiskInfo) [
      (vim.vm.GuestInfo.DiskInfo) {
         diskPath = "/",
         capacity = 14567194624,
         freeSpace = 8303763456
      },
      (vim.vm.GuestInfo.DiskInfo) {
         diskPath = "/boot",
         capacity = 499355648,
         freeSpace = 430814208
      }
   ],
...

Additional info:

Comment 2 Ravindra Kumar 2018-04-26 19:28:59 UTC
We report the disk space usage at the guest level.

My understanding is, fixing this bug will require system container (that is running open-vm-tools) to be configured with read access to all mount points on the base OS. Basically, open-vm-tools container should be able to query and report the disk space usage for all mount points/file systems known to the base OS.

Comment 4 davis phillips 2018-05-15 16:04:17 UTC
Hey Ravindra,

I've mounted the root filesystem of the container under /host. 

It's listed in /etc/mtab as well. The bind mount has been marked as slave so that any new filesystems mounted on it are propagated to the container.

The one caveat is that there are a bunch of listings in mtab for the container:

[root@atomic-00 /]# cat /proc/mounts  | wc -l
190

[root@atomic-00 open-vm-tools]# cat /proc/mounts  | wc -l
38

Will this cause any issues for the daemon? 

Is there any logging I can enable to test further?

Comment 5 Ravindra Kumar 2018-05-15 23:09:38 UTC
(In reply to davis phillips from comment #4)
> I've mounted the root filesystem of the container under /host. 

Would this make all mount points show up with "/host" prefix in the container? If yes, this might be confusing because there would be no such mount point on the Atomic Host.

> It's listed in /etc/mtab as well. The bind mount has been marked as slave so
> that any new filesystems mounted on it are propagated to the container.
> 
> The one caveat is that there are a bunch of listings in mtab for the
> container:
> 
> [root@atomic-00 /]# cat /proc/mounts  | wc -l
> 190
> 
> [root@atomic-00 open-vm-tools]# cat /proc/mounts  | wc -l
> 38
> 
> Will this cause any issues for the daemon? 

We don't really care about mtab entries that are container specific. What we really care for are the file systems/volumes configured on the host.

> Is there any logging I can enable to test further?

You can configure /etc/vmware-tools/tools.conf with following settings to make vmtoolsd generate more logs:

[logging]
vmsvc.level=debug

You can see the log messages in /var/log/vmware-vmsvc.log inside the container. vmtoolsd collects diskInfo every 30 seconds by default.

You can also check from the ESXi host side the guestInfo reported for the VM by running following commands on the ESXi host:

1. Get the VMID (first column in the output contains the VMID)
   # vim-cmd vmsvc/getallvms 

2. See guestInfo for the VM that includes diskInfo
   # vim-cmd vmsvc/get.guest <vmid>

Comment 8 RHEL Program Management 2021-02-15 07:38:42 UTC
After evaluating this issue, there are no plans to address it further or fix it in an upcoming release.  Therefore, it is being closed.  If plans change such that this issue will be fixed in an upcoming release, then the bug can be reopened.


Note You need to log in before you can comment on or make changes to this bug.