Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1572067 - can't search in external providers
Summary: can't search in external providers
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RestAPI
Version: 4.2.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.2.4
: ---
Assignee: Ondra Machacek
QA Contact: Lucie Leistnerova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-26 06:38 UTC by Lucie Leistnerova
Modified: 2018-06-26 08:46 UTC (History)
3 users (show)

Fixed In Version: ovirt-engine-4.2.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 08:46:22 UTC
oVirt Team: Infra
rule-engine: ovirt-4.2+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 90898 0 master MERGED restapi: Fix search in external providers 2018-05-07 09:54:22 UTC
oVirt gerrit 90962 0 ovirt-engine-4.2 MERGED restapi: Fix search in external providers 2018-05-08 08:19:14 UTC

Description Lucie Leistnerova 2018-04-26 06:38:07 UTC
Description of problem:
Searching external provider by the name that exists in the engine, returns empty result.

Version-Release number of selected component (if applicable):
ovirt-engine-restapi-4.2.3.2-0.1.el7.noarch

How reproducible: always


Steps to Reproduce:
1. run search
curl -k -u admin@internal:password -H "Prefer: persistent-auth" https://engine/ovirt-engine/api/openstackimageproviders/?search=name%3Drhevm-qe-brq-glance


Actual results: empty result, even when the provider is listed in result without search

<openstack_image_providers/>


Expected results: provider rhevm-qe-brq-glance

<openstack_image_providers>
    <openstack_image_provider href="/ovirt-engine/api/openstackimageproviders/b1a10d74-c443-4202-a710-827b25802ef2" id="b1a10d74-c443-4202-a710-827b25802ef2">
        <actions>
            <link href="/ovirt-engine/api/openstackimageproviders/b1a10d74-c443-4202-a710-827b25802ef2/importcertificates" rel="importcertificates"/>
            <link href="/ovirt-engine/api/openstackimageproviders/b1a10d74-c443-4202-a710-827b25802ef2/testconnectivity" rel="testconnectivity"/>
        </actions>
        <name>rhevm-qe-brq-glance</name>
        <description></description>
        ...
    </openstack_image_provider>
</openstack_image_providers>



Additional info:
The same is for
/openstacknetworkproviders?search=name%3Dovirt-provider-ovn
and probably for others too, but I did not test them (externalhostproviders, openstackvolumeproviders).

Comment 1 Lucie Leistnerova 2018-05-30 08:35:57 UTC
search returned proper result for openstackimageproviders, openstacknetworkproviders, externalhostproviders and openstackvolumeproviders

verified in ovirt-engine-restapi-4.2.4-0.1.el7.noarch

Comment 2 Sandro Bonazzola 2018-06-26 08:46:22 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.