Bug 1572076 - Dictionary response is not captured in syncop_(f)xattrop
Summary: Dictionary response is not captured in syncop_(f)xattrop
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Karthik U S
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-26 07:04 UTC by Karthik U S
Modified: 2018-06-20 18:05 UTC (History)
1 user (show)

Fixed In Version: glusterfs-v4.1.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-20 18:05:40 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Karthik U S 2018-04-26 07:04:19 UTC
Description of problem:
In the syncop_xattrop_cbk we are not capturing the response dict anywhere. Without this it is not able to get the current values of the xattrs which are set.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2018-04-26 07:13:14 UTC
REVIEW: https://review.gluster.org/19943 (libglusterfs: Capture the dict response in syncop_xattrop_cbk) posted (#1) for review on master by Karthik U S

Comment 2 Worker Ant 2018-04-27 10:26:04 UTC
COMMIT: https://review.gluster.org/19943 committed in master by "Karthik U S" <ksubrahm@redhat.com> with a commit message- libglusterfs: Capture the dict response in syncop_xattrop_cbk

Problem:
Currently it is not possible to capture the xattrs values which
are set on the bricks by calling syncop_(f)xattrop, because the
response dict is not being assigned to any of the dictionaries.

Fix:
In the xattrop callback capture the response dict and send it
back to the caller if it is requested.

Change-Id: I9de9bcd97d6008091c9b060bcca3676cb9ae8ef9
fixes: bz#1572076
Signed-off-by: karthik-us <ksubrahm@redhat.com>

Comment 3 Shyamsundar 2018-06-20 18:05:40 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v4.1.0, please open a new bug report.

glusterfs-v4.1.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-June/000102.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.