Bug 1572106 - [abrt] vkmark: vk::Instance::enumeratePhysicalDevices<std::allocator<vk::PhysicalDevice> >(): vkmark killed by SIGABRT
Summary: [abrt] vkmark: vk::Instance::enumeratePhysicalDevices<std::allocator<vk::Phys...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: vulkan
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: leigh scott
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:29991b73f06f3348857fad01ed2...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-26 08:08 UTC by Andrea Mastellone
Modified: 2019-01-08 10:15 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-08 10:15:49 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (26.86 KB, text/plain)
2018-04-26 08:08 UTC, Andrea Mastellone
no flags Details
File: cgroup (399 bytes, text/plain)
2018-04-26 08:08 UTC, Andrea Mastellone
no flags Details
File: core_backtrace (2.11 KB, text/plain)
2018-04-26 08:08 UTC, Andrea Mastellone
no flags Details
File: cpuinfo (1.26 KB, text/plain)
2018-04-26 08:08 UTC, Andrea Mastellone
no flags Details
File: dso_list (4.14 KB, text/plain)
2018-04-26 08:08 UTC, Andrea Mastellone
no flags Details
File: environ (5.92 KB, text/plain)
2018-04-26 08:08 UTC, Andrea Mastellone
no flags Details
File: limits (1.29 KB, text/plain)
2018-04-26 08:08 UTC, Andrea Mastellone
no flags Details
File: maps (19.03 KB, text/plain)
2018-04-26 08:08 UTC, Andrea Mastellone
no flags Details
File: mountinfo (3.89 KB, text/plain)
2018-04-26 08:08 UTC, Andrea Mastellone
no flags Details
File: open_fds (192 bytes, text/plain)
2018-04-26 08:08 UTC, Andrea Mastellone
no flags Details
File: proc_pid_status (1.25 KB, text/plain)
2018-04-26 08:08 UTC, Andrea Mastellone
no flags Details
Dmesg output (62.03 KB, text/plain)
2018-04-27 08:14 UTC, Andrea Mastellone
no flags Details

Description Andrea Mastellone 2018-04-26 08:08:30 UTC
Description of problem:
Fresh install od fedora 28 beta, launching vkmark simple fails.

Version-Release number of selected component:
vkmark-2017.08-0.3.20180123git68b6f23.fc28

Additional info:
reporter:       libreport-2.9.4
backtrace_rating: 4
cmdline:        vkmark
crash_function: vk::Instance::enumeratePhysicalDevices<std::allocator<vk::PhysicalDevice> >
executable:     /usr/bin/vkmark
journald_cursor: s=c7b26c21c6c344c892de1f9a779dda66;i=52d1;b=36365bcc8ebb45fa8832207d3fc1b86c;m=c603ce39;t=56abbccecfbff;x=d5cd88c8aa741919
kernel:         4.16.3-301.fc28.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (3 frames)
 #4 vk::Instance::enumeratePhysicalDevices<std::allocator<vk::PhysicalDevice> > at /usr/include/c++/8/bits/char_traits.h:350
 #5 VulkanState::choose_physical_device(VulkanWSI&) at ../src/vulkan_state.cpp:69
 #6 VulkanState::VulkanState(VulkanWSI&) at ../src/vulkan_state.cpp:34

Comment 1 Andrea Mastellone 2018-04-26 08:08:35 UTC
Created attachment 1427026 [details]
File: backtrace

Comment 2 Andrea Mastellone 2018-04-26 08:08:37 UTC
Created attachment 1427027 [details]
File: cgroup

Comment 3 Andrea Mastellone 2018-04-26 08:08:38 UTC
Created attachment 1427028 [details]
File: core_backtrace

Comment 4 Andrea Mastellone 2018-04-26 08:08:39 UTC
Created attachment 1427029 [details]
File: cpuinfo

Comment 5 Andrea Mastellone 2018-04-26 08:08:41 UTC
Created attachment 1427030 [details]
File: dso_list

Comment 6 Andrea Mastellone 2018-04-26 08:08:42 UTC
Created attachment 1427031 [details]
File: environ

Comment 7 Andrea Mastellone 2018-04-26 08:08:43 UTC
Created attachment 1427032 [details]
File: limits

Comment 8 Andrea Mastellone 2018-04-26 08:08:45 UTC
Created attachment 1427033 [details]
File: maps

Comment 9 Andrea Mastellone 2018-04-26 08:08:46 UTC
Created attachment 1427034 [details]
File: mountinfo

Comment 10 Andrea Mastellone 2018-04-26 08:08:47 UTC
Created attachment 1427035 [details]
File: open_fds

Comment 11 Andrea Mastellone 2018-04-26 08:08:48 UTC
Created attachment 1427036 [details]
File: proc_pid_status

Comment 12 Yanko Kaneti 2018-04-26 08:30:37 UTC
The assertion is on the vulkan side and probably specific to your hardware config + fedora drivers. I'll move to vulkan for now where people might have a better idea.

Comment 13 leigh scott 2018-04-26 10:56:08 UTC
What graphics hardware do you have? as vulkan will run the first driver icd even if it's headless.

Comment 14 Andrea Mastellone 2018-04-26 12:10:41 UTC
(In reply to leigh scott from comment #13)
> What graphics hardware do you have? as vulkan will run the first driver icd
> even if it's headless.

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Oland XT [Radeon HD 8670 / R7 250/350] (prog-if 00 [VGA controller])
	Subsystem: Dell Radeon R7 250
	Flags: bus master, fast devsel, latency 0, IRQ 30
	Memory at e0000000 (64-bit, prefetchable) [size=256M]
	Memory at f7e00000 (64-bit, non-prefetchable) [size=256K]
	I/O ports at e000 [size=256]
	Expansion ROM at 000c0000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: radeon
	Kernel modules: radeon, amdgpu

Comment 15 leigh scott 2018-04-26 12:21:43 UTC
I can't reproduce the issue here, maybe the open source driver is at fault.


$ vkmark -p immediate
=======================================================
    vkmark 2017.08
=======================================================
    Vendor ID:      0x10DE
    Device ID:      0x1C82
    Device Name:    GeForce GTX 1050 Ti
    Driver Version: 1661239296
=======================================================
[vertex] device-local=true: FPS: 5396 FrameTime: 0.185 ms
[vertex] device-local=false: FPS: 2883 FrameTime: 0.347 ms
[texture] anisotropy=0: FPS: 5164 FrameTime: 0.194 ms
[texture] anisotropy=16: FPS: 5117 FrameTime: 0.195 ms
[shading] shading=gouraud: FPS: 5137 FrameTime: 0.195 ms
[shading] shading=blinn-phong-inf: FPS: 5114 FrameTime: 0.196 ms
[shading] shading=phong: FPS: 5013 FrameTime: 0.199 ms
[shading] shading=cel: FPS: 5046 FrameTime: 0.198 ms
[effect2d] kernel=edge: FPS: 5340 FrameTime: 0.187 ms
[effect2d] kernel=blur: FPS: 4050 FrameTime: 0.247 ms
[desktop] <default>: FPS: 4322 FrameTime: 0.231 ms
[cube] <default>: FPS: 6806 FrameTime: 0.147 ms
[clear] <default>: FPS: 6776 FrameTime: 0.148 ms
=======================================================
                                   vkmark Score: 5089
=======================================================


$ rpm -q vulkan vkmark
vulkan-1.1.73.0-1.fc28.x86_64
vkmark-2017.08-0.3.20180123git68b6f23.fc28.x86_64

Comment 16 leigh scott 2018-04-26 12:24:35 UTC
I can't debug further as I only have nvidia hardware with nvidia.com driver and no easy way to test under wayland.

Comment 17 Dave Airlie 2018-04-26 19:38:02 UTC
Can you post dmesg, I'm expecting you don't have drivers in place for this, we need to use the amdgpu driver on oland hw to support vulkan.

Comment 18 Andrea Mastellone 2018-04-27 08:14:43 UTC
Created attachment 1427577 [details]
Dmesg output

Comment 19 Andrea Mastellone 2019-01-08 10:15:49 UTC
I become aware that the issue originated by an hardware problem. Infacts the PCI express slot where the card was inserted has a damaged connection. I have changed slot and the card works flawlessly now. So, I close this bug.


Note You need to log in before you can comment on or make changes to this bug.