Bug 1572109 - Top of font is somewhat cut in terminal on web from latest Chrome
Summary: Top of font is somewhat cut in terminal on web from latest Chrome
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-26 08:13 UTC by Xingxing Xia
Modified: 2019-11-21 12:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-21 12:56:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
top of font from latest Chrome (deleted)
2018-04-26 08:13 UTC, Xingxing Xia
no flags Details

Description Xingxing Xia 2018-04-26 08:13:54 UTC
Description of problem:
Top of font is somewhat cut in terminal on web from Chrome (latest version 66). Firefox doesn't meet.

Version-Release number of selected component (if applicable):
OpenShift Master:         v3.10.0-0.29.0
Kubernetes Master:        v1.10.0+b81c8f8
OpenShift Web Console:    v3.10.0-0.29.0

How reproducible:
Always

Steps to Reproduce:
1. Go to pod Terminal tab on Chrome
2. Execute something, check font in terminal


Actual results:
2. Top of font is somewhat cut

Expected results:
2. Top of font seen

Additional info:
As far as tried, Chrome 63 and 66 reproduce, Chrome 64 and 65 don't.

Comment 1 Robb Hamilton 2018-04-26 18:40:42 UTC
Unfortunately, this is a known issue in xterm.js v3.x.  https://github.com/xtermjs/xterm.js/issues/1170

Note https://github.com/xtermjs/xterm.js/issues/1170#issuecomment-367805363

Comment 2 Stephen Cuppett 2019-11-21 12:56:43 UTC
OCP 3.6-3.10 is no longer on full support [1]. Marking un-triaged bugs CLOSED DEFERRED. If you have a customer case with a support exception or have reproduced on 3.11+, please reopen and include those details. When reopening, please set the Version to the appropriate version where reproduced.

[1]: https://access.redhat.com/support/policy/updates/openshift


Note You need to log in before you can comment on or make changes to this bug.