Bug 1572113 - Switch for container YAML changes through the commands of the FFWD Upgrade Process
Summary: Switch for container YAML changes through the commands of the FFWD Upgrade Pr...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: 14.0 (Rocky)
Assignee: Marios Andreou
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks: 1585692 1586093 1586095
TreeView+ depends on / blocked
 
Reported: 2018-04-26 08:27 UTC by Darin Sorrentino
Modified: 2019-01-11 11:49 UTC (History)
14 users (show)

Fixed In Version: python-tripleoclient-9.2.6-2.el7ost openstack-tripleo-common-8.6.6-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1585692 1586093 1586095 (view as bug list)
Environment:
Last Closed: 2019-01-11 11:49:38 UTC
Target Upstream Version:


Attachments (Terms of Use)
how to test https://review.openstack.org/#/q/topic:remove-container-registry-file (1.96 KB, text/plain)
2018-06-01 14:04 UTC, Marios Andreou
no flags Details


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 570893 None master: MERGED python-tripleoclient: Remove --container-registry-file parameter from * upgrade clis (Id2811dbef59d1be2a35cea062eb711664... 2018-10-12 14:32:32 UTC
OpenStack gerrit 571186 None master: MERGED tripleo-common: Remove container_registry param from package update action (I4130dd1eea6caec82dcb4a699875f2951693148f) 2018-10-12 14:32:26 UTC
Red Hat Product Errata RHEA-2019:0045 None None None 2019-01-11 11:49:58 UTC

Description Darin Sorrentino 2018-04-26 08:27:25 UTC
Description of problem:
 In the FFWD Upgrade process from Newton->Queens (OSP10->OSP13), there's inconsistency in how the container images file is added to the command line.  The converge step seems to need a -e as opposed to using --container-registry-file :

openstack overcloud ffwd-upgrade prepare --templates \
  --container-registry-file /home/stack/templates/overcloud_images.yaml \
...<ENV FILES>


openstack overcloud ffwd-upgrade converge --templates \
  -e /home/stack/templates/overcloud_images.yaml \
...<ENV FILES>

openstack overcloud ceph-upgrade run --templates \
  --container-registry-file /home/stack/templates/overcloud_images.yaml \
...<ENV FILES>

It doesn't matter which we choose, '-e' or '--containter-registry-file', let's just make it consistent across the process.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Jose Luis Franco 2018-05-21 15:44:38 UTC
Considering we are out of time for GA, we will propose a more uniform use of the arguments in next release's CLI arguments for FFWD. The most probable case will be the removal of --container-registry-file option in favor of -e, treating it as another environment file.

Comment 3 Marios Andreou 2018-06-01 14:04:24 UTC
Created attachment 1446701 [details]
how to test https://review.openstack.org/#/q/topic:remove-container-registry-file

Adding reviews from https://review.openstack.org/#/q/topic:remove-container-registry-file

I sanity checked this on my environment today and ran upgrade prepare/converge without explosions. If you want to test see attachment.

The reviews in trackers address this for ceph-upgrade/ffwd-upgrade/upgrade/update but i fear we probably still need to clone this bz for each of those

Comment 4 Marios Andreou 2018-06-05 13:47:49 UTC
as per comment #3 and irc yesterday cloned this for the various clis. This one is for ffwd-upgrade so

major-upgrade at https://bugzilla.redhat.com/show_bug.cgi?id=1585692
minor update at https://bugzilla.redhat.com/show_bug.cgi?id=1586093
ceph-upgrade at https://bugzilla.redhat.com/show_bug.cgi?id=1586095

Comment 8 Dan Macpherson 2018-06-11 15:04:57 UTC
Thanks, marios. mcornea alerted me to this change, so I've implemented a fix for it:

https://gitlab.cee.redhat.com/rhci-documentation/docs-Red_Hat_Enterprise_Linux_OpenStack_Platform/commit/1a4ec051ee1c53c3291f84f4056efb67b8abed3a

Have a look and let me know if this is okay.

Comment 9 Marios Andreou 2018-06-12 05:40:38 UTC
thanks Dan! Looks OK, just spotted another nit in the example see https://gitlab.cee.redhat.com/mandreou/docs-Red_Hat_Enterprise_Linux_OpenStack_Platform/commit/e66d99b51b7c800854a01f0d8b492ee9e945e4a9

Also, there will be a warning displayed now that we are no longer using the --container-registry-file and instead pass the container image file with -e. So we should probably include a note about it in the docs? See comment #5 or https://github.com/openstack/python-tripleoclient/blob/74abcc35595d92c39c18d3008ac8df043eff16b6/tripleoclient/utils.py#L984-L990 for the wording of the message that the operator will see.

i.e. even though you see the warning, as long as you pass the images with -e it is ok.

thanks again.

Comment 10 Dan Macpherson 2018-06-14 01:48:42 UTC
Thanks, marios. Also spotted another example. Have fixed both and added the note about the message:

https://gitlab.cee.redhat.com/rhci-documentation/docs-Red_Hat_Enterprise_Linux_OpenStack_Platform/commit/73ca29073164c1c9e035920cd39f422f17531e03

Comment 11 Marios Andreou 2018-06-14 15:58:51 UTC
lgtm but possible s/might/will but up to you ;) thanks very much

Comment 14 Sofer Athlan-Guyot 2018-11-16 15:53:38 UTC
Hi,

So this can be closed as done as this is exactly the same problem and the same solution than https://bugzilla.redhat.com/show_bug.cgi?id=1586095 and https://bugzilla.redhat.com/show_bug.cgi?id=1585692 and https://bugzilla.redhat.com/show_bug.cgi?id=1586093

I don't know why it has been tagged osp14, but 13 is the place.

Moving this to modified, but really this should be closed, the same as the above bz.

Comment 18 errata-xmlrpc 2019-01-11 11:49:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:0045


Note You need to log in before you can comment on or make changes to this bug.