Bug 1572122 - After moving the Openstack Services to Containers, the non-containerized configs under /etc should be cleaned up.
Summary: After moving the Openstack Services to Containers, the non-containerized conf...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: zstream
: 13.0 (Queens)
Assignee: Sergii Golovatiuk
QA Contact: Gurenko Alex
URL:
Whiteboard:
: 1597875 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-26 08:55 UTC by Darin Sorrentino
Modified: 2020-01-27 14:22 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-13 10:51:49 UTC
Target Upstream Version:
dsorrent: needinfo-


Attachments (Terms of Use)

Description Darin Sorrentino 2018-04-26 08:55:09 UTC
Description of problem:

At the conclusion of the process, all services are containerized however the original versions of the configuration files are left in /etc.  

This may become confusing for our customers if they are trying to troubleshoot or make post-deployment configurations of the environment especially since they are moving from a non-containerized environment (Newton/OSP10) to a containerized environment (Queens/OSP13).


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 6 Carlos Camacho 2018-07-23 12:14:57 UTC
Hey Sergii, any update for this?

Comment 8 Sergii Golovatiuk 2018-08-01 18:30:44 UTC
UpgradeRemoveUnusedPackages should take care of Unused package. However, it's not covered by CI. So, it may fail any time...

Comment 9 Sergii Golovatiuk 2018-08-07 14:59:47 UTC
*** Bug 1597875 has been marked as a duplicate of this bug. ***

Comment 10 Sergii Golovatiuk 2018-08-07 15:01:04 UTC
systemd/system V services should be removed also

Comment 11 Carlos Camacho 2018-08-13 10:49:27 UTC
We need CI coverage for testing UpgradeRemoveUnusedPackages

Comment 12 Carlos Camacho 2018-08-13 10:51:49 UTC
Hi Darin,

We have a mechanism to clean up the config.

Please provide information if using UpgradeRemoveUnusedPackages works for you.

As we have a current way to achieve this I'll close this as not a bug. Please feel free to reopen this if you are not able to find a proper solution.

Comment 13 Darin Sorrentino 2020-01-27 14:21:56 UTC
This is a sufficient solution.


Note You need to log in before you can comment on or make changes to this bug.