Bug 1572148 - Fencing takes too long when first agent is unreachable
Summary: Fencing takes too long when first agent is unreachable
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Infra
Version: 4.2.3.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-4.2.4
: ---
Assignee: Eli Mesika
QA Contact: Pavol Brilla
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-26 09:37 UTC by Petr Matyáš
Modified: 2018-06-26 08:36 UTC (History)
5 users (show)

Fixed In Version: ovirt-engine-4.2.4.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 08:36:50 UTC
oVirt Team: Infra
rule-engine: ovirt-4.2+
lsvaty: testing_ack+


Attachments (Terms of Use)
engine log (4.21 MB, text/plain)
2018-04-26 09:37 UTC, Petr Matyáš
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 90819 master MERGED core: Handling unreachable agent in fencing flow 2018-05-22 13:31:06 UTC
oVirt gerrit 91690 ovirt-engine-4.2 MERGED core: Handling unreachable agent in fencing flow 2018-05-29 07:39:00 UTC

Description Petr Matyáš 2018-04-26 09:37:50 UTC
Created attachment 1427103 [details]
engine log

Description of problem:
When trying to fence a host with unreachable first agent (not concurrent) the fencing now takes 3 times as long as with the first agent reachable.
Before this took about the same as it tried to use the second agent right after 3 attempts between which were no timeouts, now there is a 3 minute timeout after failed fence action after which it tries the same agent again (4 times), thus fencing takes 20 minutes.

Version-Release number of selected component (if applicable):
ovirt-engine-4.2.3.2-0.1.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. add fake fencing agent to a host
2. add second fencing agent to a host (this one should work)
3. execute fence action restart

Actual results:
host takes 20 minutes to be fenced

Expected results:
this action should not try the same fencing agent so often and with so large timeouts between retries

Additional info:

Comment 1 Pavol Brilla 2018-06-08 11:45:10 UTC
Verified on: ovirt-engine-4.2.4.1-0.1.el7.noarch

2nd fencing device used if 1st one was faulty

Comment 2 Sandro Bonazzola 2018-06-26 08:36:50 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.