Bug 157215 - magma packaging review
magma packaging review
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: magma (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Feist
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-09 10:54 EDT by Joe Orton
Modified: 2010-01-04 14:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-04 14:08:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2005-05-09 10:54:44 EDT
magma-1.0-0.pre21.7.i386

1. the actual library files /lib/libmagma*.so.* should be executable

2. libmagma.so should be linked against libraries on which it depends - missing
-lpthread -ldl:

$ ldd -r libmagma.so.1.0.0.pre21
ldd: warning: you do not have execution permission for `./libmagma.so.1.0.0.pre21'
undefined symbol: pthread_rwlock_rdlock (./libmagma.so.1.0.0.pre21)
undefined symbol: pthread_rwlock_unlock (./libmagma.so.1.0.0.pre21)
undefined symbol: dlclose       (./libmagma.so.1.0.0.pre21)
undefined symbol: dlopen        (./libmagma.so.1.0.0.pre21)
undefined symbol: pthread_rwlock_wrlock (./libmagma.so.1.0.0.pre21)
undefined symbol: dlsym (./libmagma.so.1.0.0.pre21)
        linux-gate.so.1 =>  (0x00982000)
        libc.so.6 => /lib/libc.so.6 (0x003e2000)
        /lib/ld-linux.so.2 (0x003c0000)

3. likewise, libmagmamsg looks like it should be linked against -lmagma:

$ ldd -r libmagmamsg.so.1.0.0.pre21
ldd: warning: you do not have execution permission for
`./libmagmamsg.so.1.0.0.pre21'
undefined symbol: clist_get_flags       (./libmagmamsg.so.1.0.0.pre21)
undefined symbol: memb_resolve_list     (./libmagmamsg.so.1.0.0.pre21)
undefined symbol: clist_set_purpose     (./libmagmamsg.so.1.0.0.pre21)
...

4. the "libmagma*.so" symlinks - if these are not needed by some package to
dlopen("libmagma.so"), then they do not need to be in /lib, and do not need to
be in the main package; they should be in %{_libdir} and owned by the -devel package

typical %files patterns to use are, for the main package::

%{_libdir}/*.so.*   [or /lib/*.so.* in this case]

and for the devel package::

%{_libdir}/*.a
%{_libdir}/*.so
[if using libtool, also *.la here]

5. the section 3 man pages:

/usr/share/man/man3/clu_connect.3.gz
/usr/share/man/man3/clu_disconnect.3.gz
/usr/share/man/man3/clu_get_event.3.gz

should be in the -devel package
Comment 1 Chris Feist 2005-05-09 11:51:50 EDT
Thanks, I'll get these modifications in.
Comment 2 Rahul Sundaram 2005-09-04 23:16:33 EDT
Are these modifications in now?
Comment 3 Chris Feist 2005-09-06 12:21:13 EDT
It should be fixed in RHEL4U3.
Comment 4 Chris Feist 2005-11-15 10:57:19 EST
These fixes should be built in magma-1.0.3-2 and later.

Note You need to log in before you can comment on or make changes to this bug.