Bug 1572156 - qt5-qtwebkit in epel break the latest redhat update to version 7.5
Summary: qt5-qtwebkit in epel break the latest redhat update to version 7.5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: qt5-qtwebkit
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-26 09:45 UTC by yashtr
Modified: 2018-05-14 19:23 UTC (History)
5 users (show)

Fixed In Version: qt5-qtwebkit-5.9.1-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-14 19:23:02 UTC


Attachments (Terms of Use)
epel breaks update. (129.39 KB, image/png)
2018-04-26 09:45 UTC, yashtr
no flags Details

Description yashtr 2018-04-26 09:45:12 UTC
Created attachment 1427104 [details]
epel breaks update.

In the recent redhat 7.5 release qt5 gets updated to 5.9.2 while other packages in the epel such as qt5-qtwebkit and qt5-qtdeclarative are at the version 5.6.2. Doing a "sudo yum update" breaks existing applications depending on qt5-qtwebkit and thus breaking the update.


Version-Release number of selected component (if applicable):
the current version (in 7.5 release) of qt5-qtbase package is 5.9.2, while the epel still holds the above-mentioned packages at version 5.6.2.


Steps to Reproduce:
1. Install qt5-qtwebkit before update.
2. sudo yum update
3. qt5-qtwebkit is broken as qt5-qtbase gets updated to higher version.

Actual results:
The system can not upgrade not without compromising the application dependent 
qt5-qtwebkit.

Expected results:
qt5-qtwebkit should have been included with redhat repos and shoud have been in sync with qt5-qtbase.

Comment 1 Rex Dieter 2018-04-26 13:34:22 UTC
This will trickier, due to rhel7's old default gcc compiler being too old to support modern qtwebkit.  We'll likely have to use devtools SCL (at least).

Comment 2 yashtr 2018-04-27 12:30:14 UTC
Is there any workaround until that is done. Also, how is it that qt5-qtbase has been built with the rhel's gcc version but qtwebkit faces problems.

Comment 3 Rex Dieter 2018-04-27 13:34:05 UTC
recent qtwebkit has higher compiler requirements than qtbase

Comment 4 Rex Dieter 2018-04-27 13:39:28 UTC
Actually, I hadn't considered building older qtwebkit against newer qtbase... I'll test to see if that actually can work or not.

Comment 5 Rex Dieter 2018-04-27 13:46:07 UTC
First try scratch build, using qtwebkit 5.9.0 :

https://koji.fedoraproject.org/koji/taskinfo?taskID=26592303

Comment 6 Rex Dieter 2018-04-27 14:05:39 UTC
Better try,
https://koji.fedoraproject.org/koji/taskinfo?taskID=26592320

Comment 7 Rex Dieter 2018-04-27 16:52:31 UTC
orion on irc pointed out availability of 5.9.1, so that's what we'll probably go with initially,
https://koji.fedoraproject.org/koji/taskinfo?taskID=26593895

Comment 8 Fedora Update System 2018-04-27 19:44:09 UTC
qt5-qtwebkit-5.9.1-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-02126b4dc1

Comment 9 Fedora Update System 2018-04-29 12:52:03 UTC
qt5-qtwebkit-5.9.1-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-02126b4dc1

Comment 10 yashtr 2018-04-30 05:43:43 UTC
Never thought that the response to the problem would be so quick. I hope that the issue gets resolved soon, thanks by the way :))

Comment 11 Ken Bass 2018-05-08 02:58:11 UTC
I tested this to build MythTV on Centos 7.5 and it worked.

Comment 12 Fedora Update System 2018-05-14 19:23:02 UTC
qt5-qtwebkit-5.9.1-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.