Bug 1572158 - [RFE] add disk sizes in Disk general tab
Summary: [RFE] add disk sizes in Disk general tab
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.2.6
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ovirt-4.2.5
: ---
Assignee: Eyal Shenitzky
QA Contact: Natalie Gavrielov
URL:
Whiteboard:
: 1601574 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-26 09:48 UTC by Roman Hodain
Modified: 2018-07-31 15:25 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 1572155
Environment:
Last Closed: 2018-07-31 15:25:19 UTC
oVirt Team: Storage
rule-engine: ovirt-4.2+
ylavi: planning_ack+
rule-engine: devel_ack+
ebenahar: testing_ack+


Attachments (Terms of Use)
Situation in 4.1 (158.32 KB, image/png)
2018-06-12 08:08 UTC, Roman Hodain
no flags Details
Screenshot from disks general tab (226.47 KB, image/png)
2018-06-18 14:13 UTC, Shir Fishbain
no flags Details
snapshot (79.63 KB, image/png)
2018-06-25 08:38 UTC, Natalie Gavrielov
no flags Details
actual virtual sizes UI - master branch (74.84 KB, image/png)
2018-06-28 10:39 UTC, Eyal Shenitzky
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 92161 0 master MERGED webadmin: show disk virtual/actual size in disk general tab 2018-06-12 14:45:25 UTC
oVirt gerrit 92243 0 ovirt-engine-4.2 MERGED webadmin: show disk virtual/actual size in disk general tab 2018-06-14 12:17:47 UTC
oVirt gerrit 92647 0 ovirt-engine-4.2 MERGED webadmin: fix row positions in SubTabDiskGeneralView 2018-07-02 12:24:48 UTC

Description Roman Hodain 2018-04-26 09:48:08 UTC
Description of problem:
The general tab of Disk (Storage->Disks->TabGeneral) does not show Sizes of the disk. This information is one of the most important information and is not there. (Virtual size, Actual Size, Total Size). A proper explanation of the size meaning should be included there as well.

Version-Release number of selected component (if applicable):
4.2.2.6

Comment 1 Yaniv Kaul 2018-06-06 14:32:19 UTC
Did it show it in 4.1?

Comment 2 Roman Hodain 2018-06-12 08:08:38 UTC
Created attachment 1450351 [details]
Situation in 4.1

There were not all the information, but there was at least the information about the virtual size. It is not perfect but now when you click on a disk in 4.2 the list disappears and you cannot see even the virtual size.

Comment 3 Eyal Shenitzky 2018-06-14 06:41:39 UTC
Need to backport, return to POST

Comment 4 Tal Nisan 2018-06-14 12:17:13 UTC
(In reply to Roman Hodain from comment #2)
> Created attachment 1450351 [details]
> Situation in 4.1
> 
> There were not all the information, but there was at least the information
> about the virtual size. It is not perfect but now when you click on a disk
> in 4.2 the list disappears and you cannot see even the virtual size.

This means it's a regression from 4.1, we want it for 4.2.4 then

Comment 5 Shir Fishbain 2018-06-18 14:13:41 UTC
Created attachment 1452656 [details]
Screenshot from disks general tab

With the latest build - 4.2.4.1-0.1.el7, the disks general tab doesn't include actual size, neither the 'images' tag view. Is the intentional?

Comment 6 Eyal Shenitzky 2018-06-18 20:52:49 UTC
(In reply to Shir Fishbain from comment #5)
> Created attachment 1452656 [details]
> Screenshot from disks general tab
> 
> With the latest build - 4.2.4.1-0.1.el7, the disks general tab doesn't
> include actual size, neither the 'images' tag view. Is the intentional?

Select a disk and check the general tab it should appear there

Comment 7 Eyal Shenitzky 2018-06-18 20:52:58 UTC
(In reply to Shir Fishbain from comment #5)
> Created attachment 1452656 [details]
> Screenshot from disks general tab
> 
> With the latest build - 4.2.4.1-0.1.el7, the disks general tab doesn't
> include actual size, neither the 'images' tag view. Is the intentional?

Select a disk and check the general tab it should appear there

Comment 9 Natalie Gavrielov 2018-06-25 08:38:09 UTC
Created attachment 1454291 [details]
snapshot

Actual size is displayed now - which is good but..
Wipe After Delete seems to be displaying the Virtual size value (instead of Yes/No) and Virtual size shows nothing.

Build: 
rhvm-4.2.4.5-0.1.el7_3.noarch

Comment 10 Eyal Shenitzky 2018-06-28 10:39:50 UTC
Created attachment 1455236 [details]
actual virtual sizes UI - master branch

Comment 11 Eyal Shenitzky 2018-06-28 10:40:12 UTC
This is strange,

It seems to display properly on the master branch.
I've added a screenshot.

Natalie, can you please supply more details on the disk you created?
is there something specific?
Which browser did you use to test it?

Comment 12 Natalie Gavrielov 2018-07-09 14:22:57 UTC
Verified using 4.2.5.1_SNAPSHOT-73.g63529de.0.scratch.master.el7ev
Now all fields look fine (Wipe After Delete, Virtual Size, Actual Size)

Comment 13 Tal Nisan 2018-07-17 10:15:55 UTC
*** Bug 1601574 has been marked as a duplicate of this bug. ***

Comment 14 Sandro Bonazzola 2018-07-31 15:25:19 UTC
This bugzilla is included in oVirt 4.2.5 release, published on July 30th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.5 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.