Bug 1572163 - atime/mtime is not restored after healing for entry self heals
Summary: atime/mtime is not restored after healing for entry self heals
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: replicate
Version: rhgs-3.4
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: RHGS 3.5.0
Assignee: Ravishankar N
QA Contact: Nag Pavan Chilakam
URL:
Whiteboard:
Depends On:
Blocks: 1696809 1734370 1741041 1741044
TreeView+ depends on / blocked
 
Reported: 2018-04-26 09:56 UTC by Vijay Avuthu
Modified: 2019-10-30 14:08 UTC (History)
6 users (show)

Fixed In Version: glusterfs-6.0-14
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1734370 (view as bug list)
Environment:
Last Closed: 2019-10-30 12:19:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1607870 1 None None None 2021-01-20 06:05:38 UTC
Red Hat Product Errata RHEA-2019:3249 0 None None None 2019-10-30 12:20:03 UTC

Internal Links: 1607870

Description Vijay Avuthu 2018-04-26 09:56:47 UTC
Description of problem:

atime/mtime is not restored after healing for entry self heals

Version-Release number of selected component (if applicable):

Build : glusterfs-3.12.2-8.el7rhgs.x86_64

How reproducible:

Always

Steps to Reproduce:

1) create 1 * 3  volume
2) create a 'dir' from mount
3) kill one brick
4) touch 'dir/file'
5) bring back brick after some time
6) after healing, mtime and ctime of 'dir' will be different, while it should be same.

Actual results:

After healing time is not same as orginal atime/ctime of the dir

From N1:

# ls -lrt /bricks/brick2/b0/
total 0
drwxr-xr-x. 2 root root 18 Apr 26 03:16 dir
#


From N2:

# ls -lrt /bricks/brick2/b1
total 0
drwxr-xr-x. 2 root root 18 Apr 26 02:47 dir
# 

Expected results:

mtime/atime should be same from all the bricks.

Comment 16 errata-xmlrpc 2019-10-30 12:19:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:3249


Note You need to log in before you can comment on or make changes to this bug.