Bug 1572180 - Implicit declaration warning due to typo in #ifdef
Summary: Implicit declaration warning due to typo in #ifdef
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: neon
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-26 10:59 UTC by Mattias Ellert
Modified: 2018-10-25 12:19 UTC (History)
2 users (show)

Fixed In Version: neon-0.30.2-6.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-25 12:19:41 UTC
Type: Bug


Attachments (Terms of Use)

Description Mattias Ellert 2018-04-26 10:59:10 UTC
Description of problem:

The buildlog

https://kojipkgs.fedoraproject.org//packages/neon/0.30.2/5.fc29/data/logs/x86_64/build.log

contains the warning

ne_socket.c:580:8: warning: implicit declaration of function 'writev'

Version-Release number of selected component (if applicable):

neon-0.30.2-5.fc29 (and others)

How reproducible:

Always

Steps to Reproduce:
1. Build the package

Actual results:

Implicit declaration warning 

Expected results:

No implicit declaration warning 

Additional info:

The reason is a typo in an #ifdef, line 30 in neon-0.30.2/src/ne_socket.c says

#ifdef HAVE_SYS_UIO_h

when it should say

#ifdef HAVE_SYS_UIO_H

(i.e. the last H should be a capital H)

Comment 2 Joe Orton 2018-06-28 16:56:21 UTC
Package: neon-0.30.2-6.fc29
Build: https://koji.fedoraproject.org/koji/buildinfo?buildID=1099591

Comment 3 Jan Kurik 2018-08-14 11:19:42 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 4 Mattias Ellert 2018-10-25 12:19:41 UTC
The build.log of the referenced build does not have a warning about implicit declaration of function 'writev'.

Closing.


Note You need to log in before you can comment on or make changes to this bug.