Bug 1572189 - It is not possible to get spice console with VM user role
Summary: It is not possible to get spice console with VM user role
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.UserPortal
Version: 4.2.2.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: bugs@ovirt.org
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-26 11:29 UTC by Roman Hodain
Modified: 2018-04-27 04:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-27 04:23:42 UTC
oVirt Team: Virt
rhodain: planning_ack?
rhodain: devel_ack?
rhodain: testing_ack?


Attachments (Terms of Use)

Description Roman Hodain 2018-04-26 11:29:02 UTC
Description of problem:
It is not possible to get spice console in the VM portal when the user is assigned only to a specific VM as the UserRole.

Version-Release number of selected component (if applicable):
4.2.2.6

How reproducible:
100%

Steps to Reproduce:
1.Create a local user: ovirt-aaa-jdbc-tool user add...
2.Create a new VM as the admin
3.Add the UserRole permission for the newly created to the created VM.
4.Log into the VM portal
5.Try to open the console.

Actual results:
Nothing happens.

Expected results:
The console is open.

Additional info:
This seems to be a regression as this scenario worked in UserPortal

Comment 1 Michal Skrivanek 2018-04-27 04:23:42 UTC
Already tracked in https://github.com/oVirt/ovirt-web-ui/issues/509


Note You need to log in before you can comment on or make changes to this bug.