Bug 1572190 - [RFE] Add paging feature to the VM portal
Summary: [RFE] Add paging feature to the VM portal
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.UserPortal
Version: 4.2.2.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: ---
: ---
Assignee: bugs@ovirt.org
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-26 11:39 UTC by Roman Hodain
Modified: 2018-04-26 18:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-26 18:19:55 UTC
oVirt Team: UX
rhodain: planning_ack?
rhodain: devel_ack?
rhodain: testing_ack?


Attachments (Terms of Use)

Description Roman Hodain 2018-04-26 11:39:42 UTC
Description of problem:
When for example a user is assigned to a single VM as a superuser the VM portal will list all the VMs in the environment (maybe another bug). The problem is that the front page is very much useless if there is a lot of VMs visible the user. It is also not possible to search for specific VMs.  

Version-Release number of selected component (if applicable):
4.2.2.6

How reproducible:
100%

Steps to Reproduce:
1.Create 50Vms
2.Assign these VMs to a user
3.Log into the portal and try to get the console from the last VM.

Actual results:
The page is not paged and the VMs are loaded on demand. That complicates the work with the VMs. you can click on a VM and get the list of the VMs. That is not intuitive and many users do not find that. I have asked a couple of users to test.

Expected results:
Add paging, search field or anything that will make the work with the portal with more VMs intuitive.

Additional info:

Comment 1 Greg Sheremeta 2018-04-26 18:19:55 UTC
Hi Roman, vm portal has its own tracker. Please open this RFE at https://github.com/oVirt/ovirt-web-ui


Note You need to log in before you can comment on or make changes to this bug.