Bug 1572236 - TLS everywhere - dnsmasq fails to start
Summary: TLS everywhere - dnsmasq fails to start
Keywords:
Status: CLOSED DUPLICATE of bug 1560741
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Assaf Muller
QA Contact: Toni Freger
URL:
Whiteboard:
Depends On:
Blocks: 1488826
TreeView+ depends on / blocked
 
Reported: 2018-04-26 13:40 UTC by Itzik Brown
Modified: 2018-05-02 09:39 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-26 17:57:37 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Itzik Brown 2018-04-26 13:40:57 UTC
Description of problem:

When using TLS everywhere and OpenDaylight dnsmasq is not started.

/var/log/containers/neutron/dhcp-agent.log shows:

2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent [-] Unable to enable dhcp for b1f0aea0-18c4-49ee-9513-5784a2e697c3.: Error: [('system library', 'fopen', 'Permission denied'), ('BIO routines', 'FILE
_CTRL', 'system lib'), ('SSL routines', 'SSL_CTX_use_PrivateKey_file', 'system lib')]
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent Traceback (most recent call last):
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent   File "/usr/lib/python2.7/site-packages/neutron/agent/dhcp/agent.py", line 144, in call_driver
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent     getattr(driver, action)(**action_kwargs)
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent   File "/usr/lib/python2.7/site-packages/neutron/agent/linux/dhcp.py", line 217, in enable
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent     interface_name = self.device_manager.setup(self.network)
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent   File "/usr/lib/python2.7/site-packages/neutron/agent/linux/dhcp.py", line 1455, in setup
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent     self.unplug(interface_name, network)
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent   File "/usr/lib/python2.7/site-packages/neutron/agent/linux/dhcp.py", line 1494, in unplug
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent     self.driver.unplug(device_name, namespace=network.namespace)
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent   File "/usr/lib/python2.7/site-packages/neutron/agent/linux/interface.py", line 390, in unplug
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent     ovs = ovs_lib.OVSBridge(bridge)
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent   File "/usr/lib/python2.7/site-packages/neutron/agent/common/ovs_lib.py", line 217, in __init__
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent     super(OVSBridge, self).__init__()
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent   File "/usr/lib/python2.7/site-packages/neutron/agent/common/ovs_lib.py", line 117, in __init__
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent     self.ovsdb = ovsdb_api.from_config(self)
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent   File "/usr/lib/python2.7/site-packages/neutron/agent/ovsdb/api.py", line 31, in from_config
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent     return iface.api_factory(context)
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent   File "/usr/lib/python2.7/site-packages/neutron/agent/ovsdb/impl_idl.py", line 49, in api_factory
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent     idl=n_connection.idl_factory(),
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent   File "/usr/lib/python2.7/site-packages/neutron/agent/ovsdb/native/connection.py", line 69, in idl_factory
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent     helper = do_get_schema_helper()
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent   File "/usr/lib/python2.7/site-packages/tenacity/__init__.py", line 214, in wrapped_f
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent     return self.call(f, *args, **kw)
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent   File "/usr/lib/python2.7/site-packages/tenacity/__init__.py", line 295, in call
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent     start_time=start_time)
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent   File "/usr/lib/python2.7/site-packages/tenacity/__init__.py", line 265, in iter
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent     raise RetryError(fut).reraise()
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent   File "/usr/lib/python2.7/site-packages/tenacity/__init__.py", line 344, in reraise
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent     raise self.last_attempt.result()
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent   File "/usr/lib/python2.7/site-packages/concurrent/futures/_base.py", line 422, in result
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent     return self.__get_result()
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent   File "/usr/lib/python2.7/site-packages/tenacity/__init__.py", line 298, in call
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent     result = fn(*args, **kwargs)
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent   File "/usr/lib/python2.7/site-packages/neutron/agent/ovsdb/native/connection.py", line 67, in do_get_schema_helper
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent     return idlutils.get_schema_helper(conn, schema_name)
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent   File "/usr/lib/python2.7/site-packages/ovsdbapp/backend/ovs_idl/idlutils.py", line 118, in get_schema_helper
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent     stream.Stream.open(connection))
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent   File "/usr/lib/python2.7/site-packages/ovs/stream.py", line 190, in open
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent     error, sock = cls._open(suffix, dscp)
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent   File "/usr/lib/python2.7/site-packages/ovs/stream.py", line 768, in _open
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent     ctx.use_privatekey_file(Stream._SSL_private_key_file)
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent   File "/usr/lib/python2.7/site-packages/OpenSSL/SSL.py", line 875, in use_privatekey_file
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent     self._raise_passphrase_exception()
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent   File "/usr/lib/python2.7/site-packages/OpenSSL/SSL.py", line 854, in _raise_passphrase_exception
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent     _raise_current_error()
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent   File "/usr/lib/python2.7/site-packages/OpenSSL/_util.py", line 54, in exception_from_error_queue
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent     raise exception_type(errors)
2018-04-26 14:13:11.507 926199 ERROR neutron.agent.dhcp.agent Error: [('system library', 'fopen', 'Permission denied'), ('BIO routines', 'FILE_CTRL', 'system lib'), ('SSL routines', 'SSL_CTX_use_PrivateKey_file', 'system lib')]


Version-Release number of selected component (if applicable):
python-neutron-12.0.2-0.20180417000454.f0072ad.el7ost.noarch
openstack-tripleo-heat-templates-8.0.2-0.20180416194362.29a5ad5.el7ost.noarch

How reproducible:


Steps to Reproduce:
1. Deploy OpenStack with TLS everywhere 
2. Create a network a network and a subnet
3. Verify that there is no dnsmasq process in the neutron_dhcp container

Actual results:


Expected results:


Additional info:

Comment 3 Assaf Muller 2018-04-26 17:57:37 UTC
Please attach an sosreport from a controller node with a DHCP agent showing that error.

Comment 5 Tim Rozet 2018-04-26 18:48:19 UTC

*** This bug has been marked as a duplicate of bug 1560741 ***


Note You need to log in before you can comment on or make changes to this bug.