Bug 1572247 - [RFE] Alerting about low space in important folders
Summary: [RFE] Alerting about low space in important folders
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.3.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: bugs@ovirt.org
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-26 14:01 UTC by Petr Kubica
Modified: 2018-04-27 09:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-27 09:11:59 UTC
oVirt Team: Infra
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

Description Petr Kubica 2018-04-26 14:01:08 UTC
Description of problem:
I met with issue about low space in /tmp folder when check for update or upgrade failed due to [1]. I think that engine should monitor and warn admin about low space in important folders. It can be a warning such as about Power Management or not having full backup.

[1] ERROR [org.ovirt.engine.core.common.utils.ansible.AnsibleExecutor] (EE-ManagedThreadFactory-commandCoordinator-Thread-5) [beebfaec-b253-48cf-936e-0bb4cc0a19c6] Ansible playbook execution failed: /tmp/ansible-inventory38539853035500887: No space left on device

Version-Release number of selected component (if applicable):
4.2.3.2-0.1.el7

Steps to Reproduce:
1. Use all free space in /tmp

Comment 1 Martin Perina 2018-04-27 09:11:59 UTC
Administrators should use other monitoring tools to monitor disk usage on engine host, this is not the role of the engine. Similarly engine doesn't monitor CPU or memory usage on engine host, it performs that only on virtualization hosts.


Note You need to log in before you can comment on or make changes to this bug.