Bug 1572275 - [regression] Missing key ID no longer displayed when checking PGP signature in mutt
Summary: [regression] Missing key ID no longer displayed when checking PGP signature i...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnupg2
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Red Hat Crypto Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-26 15:04 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2018-04-26 16:39 UTC (History)
4 users (show)

Fixed In Version: gpgme-1.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-26 16:39:28 UTC
Type: Bug


Attachments (Terms of Use)

Description Dominik 'Rathann' Mierzejewski 2018-04-26 15:04:09 UTC
Description of problem:
mutt no longer displays the missing key ID when verifying a PGP signature via gpgme and the key is not in keyring.

Version-Release number of selected component (if applicable):
mutt-1.9.2-1.fc27.x86_64
gpgme-1.9.0-6.fc27.x86_64
gnupg2-2.2.5-1.fc27.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Configure mutt to use gpgme (set crypt_use_gpgme=yes)
2. Open a PGP-signed e-mail where you don't have the signer's key in your keyring

Actual results:
Error: decryption/verification failed: General error

Expected results:
Problem signature from: KeyID BE0985349D44DD00
               created: Wed 25 Apr 2018 02:24:40 CEST
Can't verify due to a missing key or certificate

Additional info:
Downgrading back to gnupg2-2.2.5-1.fc27 fixes the issue.

Comment 1 Tomas Mraz 2018-04-26 15:41:49 UTC
The gpgme-1.10.0 should address this issue.

Comment 2 Dominik 'Rathann' Mierzejewski 2018-04-26 16:07:50 UTC
Indeed, it does (though I did have to restart mutt). Could you the dependency information to prevent selective updates from breaking stuff?

Comment 3 Tomas Mraz 2018-04-26 16:37:25 UTC
Unfortunately it was unknown at the time the gnupg2 update was created (and even pushed into stable).

I'll probably stop using automatic push to stable for future gnupg2 updates and keep them in testing for longer time.


Note You need to log in before you can comment on or make changes to this bug.