Bug 1572355 - FedRAMP requires cloud providers to use TLS v1.1 as a minimum
Summary: FedRAMP requires cloud providers to use TLS v1.1 as a minimum
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: async
: 10.0 (Newton)
Assignee: RHOS Maint
QA Contact: pkomarov
URL:
Whiteboard:
Depends On: 1553273 1572353
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-26 19:26 UTC by Harry Rybacki
Modified: 2018-06-27 23:31 UTC (History)
17 users (show)

Fixed In Version: puppet-tripleo-5.6.8-4.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1572353
Environment:
Last Closed: 2018-06-27 23:30:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1754368 None None None 2018-04-26 19:26:52 UTC
OpenStack gerrit 554422 None None None 2018-04-26 19:26:52 UTC
Red Hat Product Errata RHBA-2018:2101 None None None 2018-06-27 23:31:19 UTC

Comment 1 Harry Rybacki 2018-04-26 19:28:18 UTC
Upstream patch merged: https://review.openstack.org/#/c/554422/

Moving bug to POST

Comment 2 Lon Hohberger 2018-05-18 10:36:19 UTC
According to our records, this should be resolved by puppet-tripleo-5.6.8-6.el7ost.  This build is available now.

Comment 4 pkomarov 2018-05-31 11:22:50 UTC
Verified , 

[stack@undercloud-0 ~]$ ansible overcloud -b -mshell -a'rpm -qa|grep puppet-tripleo;grep ssl_version /usr/share/openstack-puppet/modules/tripleo/manifests/stunnel/service_proxy.pp'

core_puddle_version : 2018-05-25.1


Minimum TLS version is enforced : 

controller-1 | SUCCESS | rc=0 >>
puppet-tripleo-8.3.2-6.el7ost.noarch
# [*ssl_version*]
  $ssl_version = 'TLSv1.2'

controller-2 | SUCCESS | rc=0 >>
puppet-tripleo-8.3.2-6.el7ost.noarch
# [*ssl_version*]
  $ssl_version = 'TLSv1.2'

controller-0 | SUCCESS | rc=0 >>
puppet-tripleo-8.3.2-6.el7ost.noarch
# [*ssl_version*]
  $ssl_version = 'TLSv1.2'

overcloud-novacomputeiha-0 | SUCCESS | rc=0 >>
puppet-tripleo-8.3.2-6.el7ost.noarch
# [*ssl_version*]
  $ssl_version = 'TLSv1.2'

overcloud-novacomputeiha-1 | SUCCESS | rc=0 >>
puppet-tripleo-8.3.2-6.el7ost.noarch
# [*ssl_version*]
  $ssl_version = 'TLSv1.2'

Comment 6 errata-xmlrpc 2018-06-27 23:30:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2101


Note You need to log in before you can comment on or make changes to this bug.