Bug 1572394 - Lenovo T460s: Mouse cursor movement pauses for up to several seconds when using the touchpad
Summary: Lenovo T460s: Mouse cursor movement pauses for up to several seconds when usi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libinput
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1364850
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-26 23:54 UTC by Russell Dickenson
Modified: 2018-05-02 10:52 UTC (History)
5 users (show)

Fixed In Version: libinput-1.10.5-3.fc27 libinput-1.10.5-3.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-02 10:52:06 UTC
Type: Bug


Attachments (Terms of Use)

Description Russell Dickenson 2018-04-26 23:54:09 UTC
Description of problem: When using the touchpad to move the mouse cursor, the cursor's movement will halt for up to several seconds.


Version-Release number of selected component (if applicable): 1.10.2


How reproducible: Every time.


Steps to Reproduce:
1. Use the touchpad to move the mouse cursor.

Actual results:  The mouse cursor's movement intermittently pauses for up to several seconds.


Expected results: The mouse cursor's movement always reflects the movement of the finger's movement on the touchpad.


Additional info:

Laptop: Lenovo T460s
Operating system: Fedora Linux Workstation 27 (64-bit)
Display server: X

Comment 1 Peter Hutterer 2018-04-27 04:27:57 UTC
I vaguely remembered that I had written a patch for this in the past and after some git archeology I came up with bug 1364850. That code is still there, question is why it doesn't work anymore...

Comment 2 Fedora Update System 2018-04-27 05:29:34 UTC
libinput-1.10.5-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-5013263579

Comment 3 Fedora Update System 2018-04-27 05:40:37 UTC
libinput-1.10.5-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-c20ff89ec5

Comment 4 Fedora Update System 2018-04-27 06:52:36 UTC
libinput-1.10.5-3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-abb147f32e

Comment 5 Fedora Update System 2018-04-27 06:55:22 UTC
libinput-1.10.5-3.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-3b4b474aab

Comment 6 Sammy 2018-04-27 21:05:39 UTC
This is having a side effect for T450s pencil mouse. I turn off touchpad
and only use the pencil mouse. With this patch the pencil mouse movements
get very slow. Going back to previous F27 version 1.10.2-4 resolves the
issue.

Comment 7 Fedora Update System 2018-04-28 01:53:30 UTC
libinput-1.10.5-3.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-abb147f32e

Comment 8 Fedora Update System 2018-04-28 04:07:25 UTC
libinput-1.10.5-3.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-3b4b474aab

Comment 9 Peter Hutterer 2018-04-30 01:16:42 UTC
Sammy - pencil mouse is the trackpoint, right? If so, yes, part of this update was to add a trackpoint range for the T450s (after all the complaints of the the trackpoint being way unusably fast, e.g. https://bugs.freedesktop.org/show_bug.cgi?id=103947). Please file a separate bug for this so we can look at the details, thanks.

Comment 10 Fedora Update System 2018-04-30 16:36:58 UTC
libinput-1.10.5-3.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Jon Disnard 2018-05-01 14:48:09 UTC
The problem statement does not seem resolved by libinput-1.10.5-3.fc28, at least in my case.

Lenovo w541, f28 beta.

The trackpad has the stuttering/pausing pointer issue, and also external usb mouse.

Comment 12 Peter Hutterer 2018-05-01 22:59:38 UTC
Jon: I'll probably need another bug for this because I've verified that this one fixed the T460 issue myself. Which means that the w541 likely sends some other events and we need to collect all the info.

Comment 13 Fedora Update System 2018-05-02 10:52:06 UTC
libinput-1.10.5-3.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.