Bug 1572434 - collectd-disk (ovirt-4.2-centos-opstools) conflicts with collectd (epel) when trying to install oVirt ovirt-hosted-engine-setup package
Summary: collectd-disk (ovirt-4.2-centos-opstools) conflicts with collectd (epel) when...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Packaging.rpm
Version: 2.2.16
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Simone Tiraboschi
QA Contact: Liran Rotenberg
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-27 01:57 UTC by Sam McLeod
Modified: 2018-04-30 07:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-30 07:24:01 UTC
oVirt Team: Integration


Attachments (Terms of Use)
yum install log with conflicts resulting in failure (164.11 KB, text/plain)
2018-04-27 01:57 UTC, Sam McLeod
no flags Details

Description Sam McLeod 2018-04-27 01:57:19 UTC
Created attachment 1427439 [details]
yum install log with conflicts resulting in failure

Description of problem:

Yum errors when trying to install ovirt-hosted-engine-setup package and dependencies.

Version-Release number of selected component (if applicable):

2.2.16-1.el7.centos

How reproducible:

Every time (today)
Did not happen prior to today

Steps to Reproduce:
1. Fresh install of CentOS 7
2. Add ovirt release RPM
3. Try to install ovirt-hosted-engine-setup

Actual results:

Transaction check error:
  file /usr/lib64/collectd/disk.so conflicts between attempted installs of collectd-disk-5.8.0-3.el7.x86_64 and collectd-5.8.0-3.el7.x86_64
  file /usr/lib64/collectd/write_http.so conflicts between attempted installs of collectd-write_http-5.8.0-3.el7.x86_64 and collectd-5.8.0-3.el7.x86_64


Expected results:

ovirt-hosted-engine-setup and dependancies to install without conflicting packages / files.

Comment 1 Sam McLeod 2018-04-27 01:58:33 UTC
See attachment for full yum install output.

Conflicting packages are:

 collectd                                               x86_64               5.8.0-3.el7                                        epel                                      711 k
 collectd-disk                                          x86_64               5.8.0-3.el7                                        ovirt-4.2-centos-opstools                  26 k

Comment 2 Sam McLeod 2018-04-27 02:14:00 UTC
root@s1-b2:~ 1 # yum info collectd-write_http
Loaded plugins: fastestmirror, priorities, protectbase, rpm-warm-cache, versionlock
Loading mirror speeds from cached hostfile
 * ovirt-4.2-epel: fedora.melbourneitmirror.net
0 packages excluded due to repository protections
Available Packages
Name        : collectd-write_http
Arch        : x86_64
Version     : 5.8.0
Release     : 3.el7
Size        : 33 k
Repo        : ovirt-4.2-centos-opstools/x86_64
Summary     : HTTP output plugin for collectd
URL         : https://collectd.org/
License     : MIT and GPLv2
Description : This plugin can send data to Redis.

root@s1-b2:~  # yum info collectd-disk-5.8.0-3.el7.x86_64
Loaded plugins: fastestmirror, priorities, protectbase, rpm-warm-cache, versionlock
Loading mirror speeds from cached hostfile
 * ovirt-4.2-epel: fedora.melbourneitmirror.net
0 packages excluded due to repository protections
Available Packages
Name        : collectd-disk
Arch        : x86_64
Version     : 5.8.0
Release     : 3.el7
Size        : 26 k
Repo        : ovirt-4.2-centos-opstools/x86_64
Summary     : Disk plugin for collectd
URL         : https://collectd.org/
License     : MIT and GPLv2
Description : This plugin collects statistics of harddisk and, where supported, partitions.

root@s1-b2:~  # yum info collectd-5.8.0-3.el7.x86_64
Loaded plugins: fastestmirror, priorities, protectbase, rpm-warm-cache, versionlock
Loading mirror speeds from cached hostfile
 * ovirt-4.2-epel: fedora.melbourneitmirror.net
0 packages excluded due to repository protections
Available Packages
Name        : collectd
Arch        : x86_64
Version     : 5.8.0
Release     : 3.el7
Size        : 711 k
Repo        : epel
Summary     : Statistics collection daemon for filling RRD files
URL         : https://collectd.org/
License     : GPLv2
Description : collectd is a daemon which collects system performance statistics periodically
            : and provides mechanisms to store the values in a variety of ways,
            : for example in RRD files.

Comment 3 Sam McLeod 2018-04-30 01:46:41 UTC
I've just tested with EPEL disabled, the ovirt-hosted-engine-setup package installs as expected.

I would have expected the ovirt-4.2-centos-opstools provided packages for collectd (and said plugins) to cause a package conflict rather than erroring out at package installation time.

Comment 4 Yaniv Lavi 2018-04-30 07:24:01 UTC
We do not support epel being enabled in oVirt. Since it works without that repo, I'm closing.


Note You need to log in before you can comment on or make changes to this bug.