Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1572466 - heketi is creating more volumes than requested for PVC
Summary: heketi is creating more volumes than requested for PVC
Keywords:
Status: CLOSED DUPLICATE of bug 1554467
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Michael Adam
QA Contact: Nitin Goyal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-27 05:20 UTC by Nitin Goyal
Modified: 2018-09-21 07:50 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-21 07:50:21 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Nitin Goyal 2018-04-27 05:20:14 UTC
Description of problem: I gave request to create 10 pvc at once. But heketi is creating more than 10 volumes.


Version-Release number of selected component (if applicable): 6.0.0-11


How reproducible:


Steps to Reproduce:
1. Create 10 pvc at once without any delay.

Actual results: more than 10 volumes are created.


Expected results: only 10 volumes should created.

Comment 3 Nitin Goyal 2018-04-27 05:53:51 UTC
versions of images:

[root@dhcp47-29 tmp]# docker images
REPOSITORY                                                                                 TAG                 IMAGE ID            CREATED             SIZE
brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/rhgs3/rhgs-server-rhel7               3.3.1-14            50b7fc82bf7b        7 days ago          263 MB
brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/rhgs3/rhgs-gluster-block-prov-rhel7   3.3.1-11            80bcd2848659        7 days ago          239 MB
brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/rhgs3/rhgs-volmanager-rhel7           3.3.1-11            b089a8016dfb        7 days ago          281 MB
registry.access.redhat.com/openshift3/ose-deployer                                         v3.9.14             ba9779c50c5b        4 weeks ago         1.26 GB
registry.access.redhat.com/openshift3/ose                                                  v3.9.14             078f595369ae        4 weeks ago         1.26 GB
registry.access.redhat.com/openshift3/registry-console                                     v3.9                c7c3a2d7a678        4 weeks ago         257 MB
registry.access.redhat.com/openshift3/ose-pod                                              v3.9.14             e598d93f5abe        4 weeks ago         209 MB

Comment 5 Nitin Goyal 2018-05-16 06:23:57 UTC
I am using one shell script to create many PVCs at once.

$ for i in {1..10}; do ./pvc_create.sh claim$i 4 ; done

This is shell script which i am using
----------------------------------------------------------------------------------
cat <<END > glusterfs-pvc-claim.yaml
kind: PersistentVolumeClaim
apiVersion: v1
metadata:
  name: $1
  annotations:
    volume.beta.kubernetes.io/storage-class: gluster-container
spec:
  accessModes:
    - ReadWriteOnce
  resources:
    requests:
      storage: $2Gi
END

oc create -f glusterfs-pvc-claim.yaml
----------------------------------------------------------------------------------

Comment 6 Raghavendra Talur 2018-09-21 07:50:21 UTC

*** This bug has been marked as a duplicate of bug 1554467 ***


Note You need to log in before you can comment on or make changes to this bug.