Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1572493 - openshift_logging_namespace default value should be openshift-logging in openshift_health_checker/openshift_checks/logging/logging.py
Summary: openshift_logging_namespace default value should be openshift-logging in open...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 3.10.z
Assignee: Jeff Cantrill
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-27 07:10 UTC by Junqi Zhao
Modified: 2019-04-09 23:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2019-04-09 23:40:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift openshift-ansible pull 8764 0 None None None 2018-06-14 14:26:28 UTC
Red Hat Product Errata RHBA-2019:0620 0 None None None 2019-04-09 23:40:52 UTC

Description Junqi Zhao 2018-04-27 07:10:19 UTC
Description of problem:
From 3.10, default value for openshift_logging_namespace is openshift-logging, roles/openshift_health_checker/openshift_checks/logging/logging.py should be modified

roles/openshift_health_checker/openshift_checks/logging/logging.py:        return self.get_var("openshift_logging_namespace", default="logging")


Version-Release number of selected component (if applicable):
# rpm -qa | grep openshift-ansible
openshift-ansible-docs-3.10.0-0.29.0.git.0.8973ee4.el7.noarch
openshift-ansible-roles-3.10.0-0.29.0.git.0.8973ee4.el7.noarch
openshift-ansible-3.10.0-0.29.0.git.0.8973ee4.el7.noarch
openshift-ansible-playbooks-3.10.0-0.29.0.git.0.8973ee4.el7.noarch


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Rich Megginson 2018-04-27 14:32:40 UTC
Luke - is this your team?

Comment 3 openshift-github-bot 2018-06-15 17:12:16 UTC
Commits pushed to master at https://github.com/openshift/openshift-ansible

https://github.com/openshift/openshift-ansible/commit/150cbfb7c4c11c857a0e9f72a76786e47dfa963e
bug 1572493. Update default logging NS in openshift_health_checker

https://github.com/openshift/openshift-ansible/commit/ea56d015ae5dea66451dbce749a3719a5c380814
Merge pull request #8764 from jcantrill/1572493_default_ns_for_health_check

bug 1572493. Update default logging NS in openshift_health_checker

Comment 5 Junqi Zhao 2019-03-18 05:42:41 UTC
default value for openshift_logging_namespace is openshift-logging now

# rpm -qa | grep openshift-ansible
openshift-ansible-3.10.126-1.git.0.d49a24a.el7.noarch
openshift-ansible-docs-3.10.126-1.git.0.d49a24a.el7.noarch
openshift-ansible-roles-3.10.126-1.git.0.d49a24a.el7.noarch
openshift-ansible-playbooks-3.10.126-1.git.0.d49a24a.el7.noarch

Comment 7 errata-xmlrpc 2019-04-09 23:40:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0620


Note You need to log in before you can comment on or make changes to this bug.