Bug 1572501 - RHEL7.5 - backtraces no longer work with systemtap but worked in RHEL7.4 - adding 'nokaslr' on kernel commandline makes them work again [rhel-7.5.z]
Summary: RHEL7.5 - backtraces no longer work with systemtap but worked in RHEL7.4 - ad...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemtap
Version: 7.5
Hardware: Unspecified
OS: Unspecified
urgent
unspecified
Target Milestone: rc
: ---
Assignee: Frank Ch. Eigler
QA Contact: Martin Cermak
Vladimír Slávik
URL:
Whiteboard:
: 1576845 (view as bug list)
Depends On: 1567356
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-27 07:28 UTC by Oneata Mircea Teodor
Modified: 2019-02-22 17:01 UTC (History)
16 users (show)

Fixed In Version: systemtap-3.2-8.el7_5
Doc Type: Bug Fix
Doc Text:
Because of changes in the kernel related to address space layout randomization (ASLR), kernel backtraces collected by the SystemTap tool were incomplete. SystemTap has been extended to handle this situation. As a result, SystemTap provides complete kernel backtraces.
Clone Of: 1567356
Environment:
Last Closed: 2018-06-26 16:48:44 UTC
Target Upstream Version:


Attachments (Terms of Use)
stap -DDEBUG_UNWIND=1 -DDEBUG_SYMBOLS -DDEBUG_TRANS --all-modules -vwe 'probe kernel.function("kmem_cache_alloc") { print_backtrace(); exit() }' >& stap_results.out (83.34 KB, text/plain)
2019-02-22 17:01 UTC, William Cohen
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1981 None None None 2018-06-26 16:49:01 UTC

Description Oneata Mircea Teodor 2018-04-27 07:28:35 UTC
This bug has been copied from bug #1567356 and has been proposed to be backported to 7.5 z-stream (EUS).

Comment 5 Jeff Moyer 2018-05-10 16:33:29 UTC
*** Bug 1576845 has been marked as a duplicate of this bug. ***

Comment 12 errata-xmlrpc 2018-06-26 16:48:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1981

Comment 13 William Cohen 2019-02-22 17:01:21 UTC
Created attachment 1537609 [details]
stap  -DDEBUG_UNWIND=1 -DDEBUG_SYMBOLS -DDEBUG_TRANS --all-modules -vwe 'probe kernel.function("kmem_cache_alloc") { print_backtrace(); exit() }' >& stap_results.out

Set more debug variables for systemtap and another run with:

stap  -DDEBUG_UNWIND=1 -DDEBUG_SYMBOLS -DDEBUG_TRANS --all-modules -vwe 'probe kernel.function("kmem_cache_alloc") { print_backtrace(); exit() }' >& stap_results.out


Note You need to log in before you can comment on or make changes to this bug.