Bug 1572507 - Storage volume creation raise Unexpected Error
Summary: Storage volume creation raise Unexpected Error
Keywords:
Status: CLOSED DUPLICATE of bug 1570570
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.9.3
Assignee: Marek Aufart
QA Contact: Nikhil Dhandre
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-27 07:45 UTC by Nikhil Dhandre
Modified: 2018-04-30 20:53 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-30 20:53:42 UTC
Category: ---
Cloudforms Team: Openstack
Target Upstream Version:


Attachments (Terms of Use)
snapshot (54.55 KB, image/png)
2018-04-27 07:45 UTC, Nikhil Dhandre
no flags Details

Description Nikhil Dhandre 2018-04-27 07:45:46 UTC
Created attachment 1427545 [details]
snapshot

Description of problem:
-------------------------------
While creating storage volume on OpenStack provider getting an unexpected error due to undefined method `my_zone' for nil:NilClass [cloud_volume/create]

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
Version 5.9.2.3.20180419182310_cab289


How reproducible:
----------------
100%


Steps to Reproduce:
-------------------
1. Add OpenStack provider
2. try to add volume with Cinder Manager


Actual results:
--------------
Error: undefined method `my_zone' for nil:NilClass [cloud_volume/create]

Expected results:
----------------
Should create volume

Additional info:
----------------
Attaching screenshot and production log [0]

[0] https://privatebin-it-iso.int.open.paas.redhat.com/?a2e593c880aa4004#2huLMSHe10L3anRwEvqMRNQknpfNGr2p6mBr4H6S1EY=

Comment 3 Scott Seago 2018-04-30 20:53:42 UTC

*** This bug has been marked as a duplicate of bug 1570570 ***


Note You need to log in before you can comment on or make changes to this bug.