Bug 1572509 - Empty error on start of metrics playbook
Summary: Empty error on start of metrics playbook
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine-metrics
Classification: oVirt
Component: Generic
Version: 1.1.4.2
Hardware: All
OS: All
low
low
Target Milestone: ovirt-4.3.1
: ---
Assignee: Shirly Radco
QA Contact: Ivana Saranova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-27 07:54 UTC by Lukas Svaty
Modified: 2019-03-13 16:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-13 16:39:33 UTC
oVirt Team: Metrics
rule-engine: ovirt-4.3+
lleistne: testing_ack+


Attachments (Terms of Use)

Description Lukas Svaty 2018-04-27 07:54:50 UTC
Description of problem:
Empty error appears on start of metrics playbooks:
# /usr/share/ovirt-engine-metrics/configure_ovirt_machines_for_metrics.sh 
 [ERROR]:

 [WARNING]: Could not match supplied host pattern, ignoring: metrics_store

Version-Release number of selected component (if applicable):
ovirt-engine-metrics-1.1.4.2-1.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Run metrics playbook
2. See first line

Actual results:
"[ERROR]: " appears after start of playbook

Expected results:
No error in logs

Additional info:
Unsure why however this does not appear if inventory/ is not set in ansible.cfg.
There was no change in inventory AFAIK

Verbose output:
# /usr/share/ovirt-engine-metrics/configure_ovirt_machines_for_metrics.sh  -vvvv
ansible-playbook 2.5.1
  config file = /usr/share/ovirt-engine-metrics/ansible.cfg
  configured module search path = [u'/root/.ansible/plugins/modules', u'/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python2.7/site-packages/ansible
  executable location = /usr/bin/ansible-playbook
  python version = 2.7.5 (default, Oct 17 2017, 09:08:33) [GCC 4.8.5 20150623 (Red Hat 4.8.5-19)]
Using /usr/share/ovirt-engine-metrics/ansible.cfg as config file
setting up inventory plugins
 [ERROR]:

Parsed /usr/share/ovirt-engine-metrics/inventory/dynamic_ovirt_hosts inventory source with script plugin
Set default localhost to localhost
Parsed /usr/share/ovirt-engine-metrics/inventory/hosts inventory source with ini plugin
 [WARNING]: Could not match supplied host pattern, ignoring: metrics_store

Loading callback plugin default of type stdout, v2.0 from /usr/lib/python2.7/site-packages/ansible/plugins/callback/default.pyc

PLAYBOOK: configure-ovirt-metrics.yml *****************************************************************************************************************************************************************************
3 plays in playbooks/configure-ovirt-metrics.yml

Comment 1 Sandro Bonazzola 2019-01-28 09:41:07 UTC
This bug has not been marked as blocker for oVirt 4.3.0.
Since we are releasing it tomorrow, January 29th, this bug has been re-targeted to 4.3.1.

Comment 2 Shirly Radco 2019-02-25 07:10:02 UTC
I dont see this error. Please check.

Comment 3 Ivana Saranova 2019-03-01 13:07:51 UTC
Steps to Reproduce:
1. Run metrics playbook
2. See first line

Result:

```
[root@engine ~]# /usr/share/ovirt-engine-metrics/setup/ansible/configure_ovirt_machines_for_metrics.sh
 [WARNING]: Could not match supplied host pattern, ignoring: metrics_store


PLAY [Add metrics store host to inventory] *************************************

TASK [Gathering Facts] *********************************************************
ok: [localhost]

```

No empty error on the first line.

Verified in: ovirt-engine-4.3.1.1-0.1.el7.noarch, ovirt-engine-metrics-1.2.0.3-1.el7ev.noarch

Comment 4 Sandro Bonazzola 2019-03-13 16:39:33 UTC
This bugzilla is included in oVirt 4.3.1 release, published on February 28th 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.1 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.