Bug 1572538 - containernetworking-plugins missing plugin "portmap" for podman run
Summary: containernetworking-plugins missing plugin "portmap" for podman run
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: podman
Version: 7.5
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Lokesh Mandvekar
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-27 09:29 UTC by Joy Pu
Modified: 2018-05-14 16:53 UTC (History)
1 user (show)

Fixed In Version: podman-0.4.1-4.gitb51d327.el7_5
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-14 16:52:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1418 0 None None None 2018-05-14 16:53:05 UTC

Description Joy Pu 2018-04-27 09:29:25 UTC
Description of problem:

The rpm is not include all plugins that we need for podman run. And podman run command will failed with this error msg:
time="2018-04-27T05:11:18-04:00" level=error msg="Error adding network: failed to find plugin "portmap" in path [/usr/libexec/cni /usr/lib/cni /opt/cni/bin /opt/bridge/bin]" 
time="2018-04-27T05:11:18-04:00" level=error msg="Error while adding to cni network: failed to find plugin "portmap" in path [/usr/libexec/cni /usr/lib/cni /opt/cni/bin /opt/bridge/bin]" 


Version-Release number of selected component (if applicable):
containernetworking-plugins-0.7.0-3.gitb51d327.el7.x86_64.rpm

How reproducible:
100%

Steps to Reproduce:
1. Try to run any container with podman
# podman run fedora ls


Actual results:
podman failed to run it and report error msg above

Expected results:
podman can start and run container as expect.

Additional info:
The first one is the file list that I build from cni upstream and the second one is I get from our rpm:

ls /usr/libexec/cni/ cni/
cni/:
bridge  dhcp  flannel  host-device  host-local  ipvlan  loopback  macvlan  portmap  ptp  sample  tuning  vlan

/usr/libexec/cni/:
bridge  dhcp  flannel  host-local  ipvlan  loopback  macvlan  ptp  sample  tuning  vlan

Comment 4 Joy Pu 2018-04-28 05:43:47 UTC
Test with containernetworking-plugins-0.7.0-4.gitb51d327.el7.x86_64.rpm and podman-0.4.1-4.gitb51d327.el7.x86_64.rpm with the same steps and it works as expact:
# podman run fedora ls
Trying to pull registry.access.redhat.com/fedora:latest...Failed
Trying to pull docker.io/fedora:latest...Getting image source signatures
Copying blob sha256:2176639d844bbe1386912e1d9952cebdb8249923a16691025cf693963f8aec53
 77.54 MB / 77.54 MB [====================================================] 1m3s
Copying config sha256:9110ae7f579f35ee0c3938696f23fe0f5fbe641738ea52eb83c2df7e9995fa17
 2.29 KB / 2.29 KB [========================================================] 0s
Writing manifest to image destination
Storing signatures
bin
boot
dev
etc
home
lib
lib64
lost+found
media
mnt
opt
proc
root
run
sbin
srv
sys
tmp
usr
var


So set this to verified.

Comment 7 errata-xmlrpc 2018-05-14 16:52:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1418


Note You need to log in before you can comment on or make changes to this bug.