Bug 1572549 - GDAL fails to configure with OpenJPEG-2.3 provided by F27 [NEEDINFO]
Summary: GDAL fails to configure with OpenJPEG-2.3 provided by F27
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: gdal
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Devrim Gündüz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-27 10:03 UTC by markusN
Modified: 2018-12-01 20:11 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-30 21:51:01 UTC
Type: Bug
neteler: needinfo? (devrim)


Attachments (Terms of Use)
Patch to fix broken openJPEG support (41.48 KB, text/plain)
2018-04-27 10:03 UTC, markusN
no flags Details
gdal-2.1.4-openjpeg.patch (8.92 KB, patch)
2018-05-17 11:42 UTC, markusN
no flags Details | Diff

Description markusN 2018-04-27 10:03:17 UTC
Created attachment 1427603 [details]
Patch to fix broken openJPEG support

Description of problem:

Reading JPEG2000 images is currently rather impossible since only the JapPer driver is activated.

Reason is the outdated GDAL version in F27 which only supports OpenJPEG-2.1 but F27 provides OpenJPEG-2.3:

https://kojipkgs.fedoraproject.org//packages/gdal/2.1.4/5.1.fc27/data/logs/x86_64/build.log
...
checking for HDF4 support in libnetcdf... yes
checking for jpc_decode in -ljasper... yes
checking for jp2_decode in -ljasper... yes
checking for pgx_decode in -ljasper... yes
checking for jp2_encode_uuid in -ljasper... no
configure: hacked JasPer version not found, GeoJP2 disabled.
checking openjpeg-2.0/openjpeg.h usability... no
checking openjpeg-2.0/openjpeg.h presence... no
checking for openjpeg-2.0/openjpeg.h... no
checking openjpeg-2.1/openjpeg.h usability... no
checking openjpeg-2.1/openjpeg.h presence... no
checking for openjpeg-2.1/openjpeg.h... no
...
  JasPer support:            yes (GeoJP2=no)
  OpenJPEG support:          no
...

Version-Release number of selected component (if applicable):
gdal-2.1.4-5.1.fc27.x86_64

Attached a patch to recognise also OpenJPEG-2.3 along with the modified SPEC file.

Comment 1 markusN 2018-04-27 12:55:19 UTC
For illustration of the current situation (solved by attached patch):

gdal_translate -co "COMPRESS=LZW" F6_dop20rgbi_32375_5630_1_nw.jp2 test.tif

Input file size is 5000, 5000
0maximum number of samples exceeded (100000000 > 67108864)
error: cannot decode code stream
ERROR 1: F6_dop20rgbi_32375_5630_1_nw.jp2, band 1: IReadBlock failed at
X offset 0, Y offset 0
ERROR 1: GetBlockRef failed at X block offset 0, Y block offset 0
...

This happens due to JasPer driver being used in absence of the better OpenJPEG2 driver.

Comment 2 markusN 2018-05-14 18:50:26 UTC
Sorry for asking, any chance to get this fix applied?

I tried to clone the fedora repo and submit a PR but permission denied...

Comment 3 Jozef Mlich 2018-05-16 10:00:59 UTC
I can see only spec file in attachment, but not the patch it self. Can you check if you attached all necessary files?

Comment 4 markusN 2018-05-17 11:42:52 UTC
Created attachment 1437926 [details]
gdal-2.1.4-openjpeg.patch

Comment 5 markusN 2018-05-17 11:45:08 UTC
(In reply to Jozef Mlich from comment #3)
> I can see only spec file in attachment, but not the patch it self. Can you
> check if you attached all necessary files?

Sorry, my bad. Now attached.

Comment 6 Ben Cotton 2018-11-27 15:18:31 UTC
This message is a reminder that Fedora 27 is nearing its end of life.
On 2018-Nov-30  Fedora will stop maintaining and issuing updates for
Fedora 27. It is Fedora's policy to close all bug reports from releases
that are no longer maintained. At that time this bug will be closed as
EOL if it remains open with a Fedora  'version' of '27'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 27 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 7 Ben Cotton 2018-11-30 21:51:01 UTC
Fedora 27 changed to end-of-life (EOL) status on 2018-11-30. Fedora 27 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Comment 8 Volker Fröhlich 2018-12-01 20:11:46 UTC
It's worth saying that this is actually resolved after F27.


Note You need to log in before you can comment on or make changes to this bug.