Bug 1572590 - Removing the assigned subscription from multiple hosts using bulk action fails. [NEEDINFO]
Summary: Removing the assigned subscription from multiple hosts using bulk action fails.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Host Collections
Version: 6.3.1
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: Released
Assignee: Samir Jha
QA Contact: Radovan Drazny
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-27 11:28 UTC by Amaani S Karimi
Modified: 2019-10-07 16:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-28 13:56:45 UTC
Target Upstream Version:
sajha: needinfo? (akarimi)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 23968 0 Normal Closed Removing the assigned subscription from multiple hosts using bulk action fails. 2020-08-19 23:57:49 UTC
Red Hat Knowledge Base (Solution) 3429811 0 None None None 2019-01-28 05:13:44 UTC

Description Amaani S Karimi 2018-04-27 11:28:34 UTC
Description of problem:

From host collection assigning subscription to multiple hosts at once is possible with bulk action but removing the subscription from them all at once using bulk action fails.


Version-Release number of selected component (if applicable):

Red Hat Satellite 6.3.1


How reproducible:

100% reproducible.

Steps to Reproduce:
1. Hosts => Host Collections => name_of_collection => Subscription Management  --> able to asign add subscriptions to a bulk group of hosts

2.Removing does not work in reality.

Actual results:
 
Shows removed but subscriptions are still there

Expected results:

It should be removed.

Comment 7 Samir Jha 2018-06-17 18:43:35 UTC
Created redmine issue http://projects.theforeman.org/issues/23968 from this bug

Comment 8 pm-sat@redhat.com 2018-07-09 14:06:49 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/23968 has been resolved.

Comment 10 Bryan Kearney 2019-05-28 13:56:45 UTC
This was delivered in 6.4.0, and I do not see this getting backported to 6.3.z. Closing this out.


Note You need to log in before you can comment on or make changes to this bug.