Bug 1572592 - [RFE] TFTP file download should be synchronous and handle errors
Summary: [RFE] TFTP file download should be synchronous and handle errors
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: TFTP
Version: 6.3.0
Hardware: All
OS: Linux
high
high
Target Milestone: Unspecified
Assignee: Dmitri Dolguikh
QA Contact: Roman Plevka
URL: https://projects.theforeman.org/issue...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-27 11:28 UTC by Varatharaja Perumal G
Modified: 2019-11-04 14:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-04 14:01:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 3034 0 Normal New TFTP file download should be synchronous and handle errors 2020-08-27 16:23:23 UTC

Description Varatharaja Perumal G 2018-04-27 11:28:52 UTC
Description of problem:

While provisioning a new host validate 'vmlinuz' & 'initrd.img' files under '/var/lib/tftpboot/boot/' which are correctly copied before provisioning the host.


Version-Release number of selected component (if applicable):

Satellite 6.3

How reproducible:

This issue will occur when we use a wrong media for the operating system or when the link is broken.

Actual results:
Fail to provision the host with below error:

ValueError: New value non-existent xfs filesystem is not valid as a default fs type

Expected results:

Host should get provision without any issue.

Additional info:

Follow the article resolve the issue.

--> https://access.redhat.com/solutions/2115301

Comment 1 Lukas Zapletal 2018-04-27 12:22:35 UTC
We are tracking this under

https://projects.theforeman.org/issues/3034

and we need to implement bigger changes around Operating System vs Content Source/View vs TFTP in order to fully fix this problem.

The corruption is also common issue we want to solve:

https://bugzilla.redhat.com/show_bug.cgi?id=1571290

Comment 2 pm-sat@redhat.com 2018-04-27 14:01:49 UTC
Upstream bug assigned to ddolguik@redhat.com

Comment 3 pm-sat@redhat.com 2018-04-27 14:01:52 UTC
Upstream bug assigned to ddolguik@redhat.com

Comment 5 Bryan Kearney 2019-11-04 14:01:01 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.