Bug 1572608 - Host fails to move to maintenance when HE VM is running on it
Summary: Host fails to move to maintenance when HE VM is running on it
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Infra
Version: 4.2.3.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.2.4
: ---
Assignee: Ravi Nori
QA Contact: Pavol Brilla
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-27 12:02 UTC by Petr Matyáš
Modified: 2018-05-09 07:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-09 07:59:36 UTC
oVirt Team: Infra
rule-engine: ovirt-4.2+
rule-engine: blocker+


Attachments (Terms of Use)
engine log (6.21 MB, text/plain)
2018-04-27 12:02 UTC, Petr Matyáš
no flags Details

Description Petr Matyáš 2018-04-27 12:02:41 UTC
Created attachment 1427639 [details]
engine log

Description of problem:
I have SHE setup with 2 hosts which both support running HE VM. When trying to upgrade host which is running the HE VM it gets stuck in moving to maintenance state, generating new task (Moving host x to maintenance) every 5 minutes in the process.

Version-Release number of selected component (if applicable):
ovirt-engine-4.2.3.3-0.1.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. have SHE setup with 2 hosts
2. upgrade host which is running the HE VM (just moving to maintenance should suffice)
3.

Actual results:
host is in state preparing for maintenance and new task of moving host to maintenance is generated every 5 minutes

Expected results:
host is upgraded (moved to maintenance)

Additional info:

Comment 1 Yaniv Kaul 2018-04-28 18:42:14 UTC
If there's a workaround, such as manually migrating the VM first, I'm not sure it's a blocker, even if it's a regression.

Comment 2 Martin Perina 2018-04-30 09:51:53 UTC
Is HE VM migrated to different host when you try to put host into Maintenance before the upgrade?

Comment 3 Martin Perina 2018-05-02 08:22:36 UTC
Host can be moved to Maintanenace mamually and upgraded afterwards, moving to 4.2.4

Comment 4 Red Hat Bugzilla Rules Engine 2018-05-02 08:22:40 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 5 Ravi Nori 2018-05-07 18:23:50 UTC
I am unable to reproduce the issue with the latest master and latest 4.2.4 builds.

The issue seems to be fixed in latest master and 4.2.4 builds. I was able to reproduce the issue on master build from a week ago. I would suggest trying with the latest builds.

Comment 6 Petr Matyáš 2018-05-09 07:59:36 UTC
You are right, on latest build this seems to be working fine.


Note You need to log in before you can comment on or make changes to this bug.