Bug 1572635 - RFE: preserve DNS options with dnsPolicy ClusterFirst
Summary: RFE: preserve DNS options with dnsPolicy ClusterFirst
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE
Version: 3.7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Derek Carr
QA Contact: Xiaoli Tian
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-27 13:18 UTC by Mauricio Magnani
Modified: 2019-06-12 11:57 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-12 11:57:17 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Mauricio Magnani 2018-04-27 13:18:01 UTC
### Description of problem ### 

Customer have made some local changes to be used by the pods in resolv.conf and  added "options timeout:2" since the default timeout of 5 seconds is not suitable for them.

This addition however is not added to pods as they are created.

###  Version-Release number ### 

openshift-ansible-3.7.42-1.git.2.9ee4e71.el7.noarch

### Steps to Reproduce: ### 

1. cat /etc/resolv.conf > /etc/origin/node/resolv.new.conf
2. echo "options timeout:2" >> /etc/origin/node/resolv.new.conf
3. - name: Update /etc/origin/node/node-config.yaml. insertafter: '^kubeletArguments:'
  resolv-conf:
   - '/etc/origin/node/resolv.new.conf'
4. systemctl restart atomic-openshift-node
5. Start pod on node
6. oc rsh <pod_name>
7. In pod: cat /etc/resolv.conf

* Actual results:

Is not working.

* Expected results:

The pod should contain "options timeout:2"

Comment 5 Kirsten Newcomer 2019-06-12 11:57:17 UTC
With the introduction of OpenShift 4, Red Hat has delivered or roadmapped a substantial number of features based on feedback by our customers.  Many of the enhancements encompass specific RFEs which have been requested, or deliver a comparable solution to a customer problem, rendering an RFE redundant.

This bz (RFE) has been identified as a feature request not yet planned or scheduled for an OpenShift release and is being closed. 

If this feature is still an active request that needs to be tracked, Red Hat Support can assist in filing a request in the new JIRA RFE system, as well as provide you with updates as the RFE progress within our planning processes. Please open a new support case: https://access.redhat.com/support/cases/#/case/new 

Opening a New Support Case: https://access.redhat.com/support/cases/#/case/new 

As the new Jira RFE system is not yet public, Red Hat Support can help answer your questions about your RFEs via the same support case system.


Note You need to log in before you can comment on or make changes to this bug.