Bug 1572717 - /var/log/journal should have group %attr set to systemd-journal in the spec file %files section
Summary: /var/log/journal should have group %attr set to systemd-journal in the spec f...
Keywords:
Status: CLOSED DUPLICATE of bug 1545372
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd
Version: 7.5
Hardware: All
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: systemd-maint
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-27 16:56 UTC by Drew H
Modified: 2019-02-07 07:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-31 13:18:13 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Drew H 2018-04-27 16:56:58 UTC
Description of problem:
/var/log/journal should not be reported by rpm -V as an error
If the /var/log/journal directory is created, systemd will set the group on this directory to systemd-journal.  The spec file does not set a group on this directory so the default value causes the verification to fail.

Version-Release number of selected component (if applicable):
systemd-219-57.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. [[ ! -d /var/log/journal ]] && mkdir -p /var/log/journal
2. reboot
3. rpm -V systemd

Actual results:
# rpm -V systemd
.M....G..  g /var/log/journal

Expected results:
No error

Additional info:

Comment 2 Jan Synacek 2018-05-09 11:22:49 UTC
In theory, we could use something like "%verify(not md5)" in the spec file, but it doesn't really matter and doesn't make much sense for a ghosted file. And since you created the directory yourself, you should also set the right permissions yourself. IMO, this is nothing to fix.

Comment 3 Drew H 2018-05-09 13:46:09 UTC
I actually can't set a permanent correct group on the directory.  That's the bug.  I can change the group on /var/log/journal to root, and it will verify correctly.  But once I reboot the system, systemd will set the group on /var/log/journal back to systemd-journal and once again fail to verify.

The spec file states in a comment in %post that the journal files *will* be owned by the systemd-journal group, but verify is checking for root.  The spec file doesn't need a %verify(not md5), it needs something like %attr(-, -, systemd-journal) to be consistent with how systemd works.

Comment 4 David Tardon 2019-01-31 13:18:13 UTC

*** This bug has been marked as a duplicate of bug 1545372 ***


Note You need to log in before you can comment on or make changes to this bug.