Bug 1572721 - Blocking engine install
Summary: Blocking engine install
Keywords:
Status: CLOSED DUPLICATE of bug 1566162
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Hosted Engine
Version: ---
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ovirt-4.2.3
: ---
Assignee: Phillip Bailey
QA Contact: Ying Cui
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-27 17:02 UTC by John
Modified: 2018-04-30 14:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-30 14:40:08 UTC
oVirt Team: Integration
rule-engine: ovirt-4.2+
rule-engine: blocker+


Attachments (Terms of Use)

Description John 2018-04-27 17:02:28 UTC
Description of problem:

Hosted Engine install blocks at the end when the ansible script waits for the hostedengine vm to shutdown.

The sshd_config accepts the LANG parameter which the iMac sends with the ssh utility, setting message outputs to the local language.
The result is that the 'virsh -r dominfo "HostedEngineLocal"' returns a State of 'Toestand: draaien' (Dutch) and not 'State: running' (or shut off).
This results in the ansible script checking forever of until it timeouts resulting in a failed deployment.

Removing the AcceptEnv LANG from sshd_config of an 'export LC_ALL=C' results in a successful hosted engine deployment.


Version-Release number of selected component (if applicable):
Version 4.2.2.6-1.el7.centos

How reproducible:


Steps to Reproduce:
1. Login via ssh or the wenbased cockpit using a non-english locale.
2. Start deploy the hosted engine.
3. Follow all steps, tail log to see ansible retrying to check for 'shut off' engine, right before the end of the install.

Actual results:
Keeps trying until timeout, then fails deployement.

Expected results:
Succesfully deployed hosted engine

Additional info:

Comment 1 Ryan Barry 2018-04-30 14:40:08 UTC
See also: 

https://gerrit.ovirt.org/#/c/90496/

We are set to resolve this in 4.2.3. However, since this is also present over SSH, it's not cockpit-ovirt.

Both issues (`hosted-engine --deploy`+ansible, and cockpit-ovirt) will be resolved.

*** This bug has been marked as a duplicate of bug 1566162 ***


Note You need to log in before you can comment on or make changes to this bug.