Bug 1572772 - Building RPMs on OpenShift fails with "error: Bad owner/group"
Summary: Building RPMs on OpenShift fails with "error: Bad owner/group"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rpm
Version: 7.5
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: Pavlina Moravcova Varekova
QA Contact: Eva Mrakova
URL:
Whiteboard:
Depends On:
Blocks: 1630909
TreeView+ depends on / blocked
 
Reported: 2018-04-27 19:30 UTC by Major Hayden
Modified: 2019-08-06 13:11 UTC (History)
6 users (show)

Fixed In Version: rpm-4.11.3-37.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 13:11:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:2259 None None None 2019-08-06 13:11:37 UTC

Description Major Hayden 2018-04-27 19:30:12 UTC
Description of problem:

When building kernels on OpenShift with userid namespacing, RPM builds fail in a check ownership step:

error: Bad owner/group: { path to source code tarball }

Version-Release number of selected component (if applicable):

  rpm-4.11.3-25.el7.x86_64

Steps to Reproduce:
  1. Create a container in OpenShift
  2. Attempt to build an RPM package
  3. The package build fails when RPM checks the ownership of the source code tarball

OpenShift uses userid namespacing, so the uid of the active user is different each time the container starts. Running commands like `whoami` will fail:

  whoami: cannot find name for user ID 1000530000

There is a fix mentioned in this thread:

  https://www.spinics.net/lists/rpm/msg08012.html

Is it possible to get that fix backported to RHEL 7? Thanks!

Comment 15 errata-xmlrpc 2019-08-06 13:11:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2259


Note You need to log in before you can comment on or make changes to this bug.